summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common/recipes-devtools
diff options
context:
space:
mode:
authorPatrick Venture <venture@google.com>2017-10-05 16:25:40 -0700
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2017-10-10 01:21:14 +0000
commitf5952ed1ab643a31ac014f8455d81f28330573b0 (patch)
tree3b76d60708495f72c06a9e8ffc759bcbf93fcd10 /meta-phosphor/common/recipes-devtools
parent7507209e80c1f60feab2edf453f0440ee17e9e62 (diff)
downloadtalos-openbmc-f5952ed1ab643a31ac014f8455d81f28330573b0.tar.gz
talos-openbmc-f5952ed1ab643a31ac014f8455d81f28330573b0.zip
devtools: iotools: add service to create symlinks
The iotools binary is meant to be called via symlinks, similarly to busybox. Therefore, the recipe should provide a service that kicks that off for the user. Change-Id: I64b69bf18bd39e324ba9c6922cdf08b88caf43e2 Signed-off-by: Patrick Venture <venture@google.com>
Diffstat (limited to 'meta-phosphor/common/recipes-devtools')
-rw-r--r--meta-phosphor/common/recipes-devtools/iotools/iotools/iotools-setup.service11
-rw-r--r--meta-phosphor/common/recipes-devtools/iotools/iotools_1.6.bb4
2 files changed, 15 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-devtools/iotools/iotools/iotools-setup.service b/meta-phosphor/common/recipes-devtools/iotools/iotools/iotools-setup.service
new file mode 100644
index 000000000..7cc95a0db
--- /dev/null
+++ b/meta-phosphor/common/recipes-devtools/iotools/iotools/iotools-setup.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=Install iotool links
+
+[Service]
+RemainAfterExit=no
+Type=oneshot
+ExecStart=/usr/bin/env iotools --make-links
+SystlogIdentifier=iotools
+
+[Install]
+WantedBy={SYSTEMD_DEFAULT_TARGET}
diff --git a/meta-phosphor/common/recipes-devtools/iotools/iotools_1.6.bb b/meta-phosphor/common/recipes-devtools/iotools/iotools_1.6.bb
index 0fc872dc1..2a3928699 100644
--- a/meta-phosphor/common/recipes-devtools/iotools/iotools_1.6.bb
+++ b/meta-phosphor/common/recipes-devtools/iotools/iotools_1.6.bb
@@ -6,6 +6,8 @@ SRCREV = "223a7be0885dd3d0dba910d55d06745bdfd846d8"
SRC_URI = "git://git@github.com/jonmayergoogle/iotools.git;protocol=https"
PV = "v1.6+git${SRCPV}"
+inherit obmc-phosphor-systemd
+
S = "${WORKDIR}/git"
FILES_${PN} = "${sbindir}"
@@ -20,3 +22,5 @@ do_install() {
install -d ${D}${sbindir}
install -m 0755 iotools ${D}${sbindir}
}
+
+SYSTEMD_SERVICE_${PN} += "iotools-setup.service"
OpenPOWER on IntegriCloud