summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common/recipes-devtools
diff options
context:
space:
mode:
authorXo Wang <xow@google.com>2016-10-24 18:44:49 -0700
committerPatrick Williams <patrick@stwcx.xyz>2016-10-31 14:42:33 +0000
commit4ef18bf263b8fc0e8197fadc3cd0dfec7105c6c6 (patch)
tree71ec19f2e69276f668e90770dc432f8de78aeada /meta-phosphor/common/recipes-devtools
parent4d17194cd0fbf912b559f8426cb4c6a2e1af6f17 (diff)
downloadtalos-openbmc-4ef18bf263b8fc0e8197fadc3cd0dfec7105c6c6.tar.gz
talos-openbmc-4ef18bf263b8fc0e8197fadc3cd0dfec7105c6c6.zip
meta-phosphor: Add iotools recipe
iotools is a command line utility for access to hardware device registers. Since iotools uses a Makefile for building and installing, this recipe includes do_compile for build options and do_install for the packaged binary. Signed-off-by: Xo Wang <xow@google.com> Change-Id: I783477d6de58a1e1868dd0383b46aa9bbe5d37ac
Diffstat (limited to 'meta-phosphor/common/recipes-devtools')
-rw-r--r--meta-phosphor/common/recipes-devtools/iotools/iotools_1.6.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-devtools/iotools/iotools_1.6.bb b/meta-phosphor/common/recipes-devtools/iotools/iotools_1.6.bb
new file mode 100644
index 000000000..e3c02c2fc
--- /dev/null
+++ b/meta-phosphor/common/recipes-devtools/iotools/iotools_1.6.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Command line tools for hardware device registers"
+HOMEPAGE = "https://github.com/adurbin/iotools"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
+SRCREV = "452ad1f4957a4f307fbe204419e5d08a1a1febb9"
+SRC_URI = "git://git@github.com/adurbin/iotools.git;protocol=https"
+PV = "v1.6+git${SRCPV}"
+
+S = "${WORKDIR}/git"
+FILES_${PN} = "${sbindir}"
+
+do_compile() {
+ # CC is overridden in the Makefile, so override it harder in the invocation
+ oe_runmake CC="${CC}" DEBUG="${DEBUG_BUILD-0}" STATIC=0
+}
+
+# The "install" make target runs the binary to create links for subcommands.
+# The links are excessive and this doesn't work for cross compiling.
+do_install() {
+ install -d ${D}${sbindir}
+ install -m 0755 iotools ${D}${sbindir}
+}
OpenPOWER on IntegriCloud