summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common/recipes-connectivity
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2016-05-26 18:03:12 -0500
committerPatrick Williams <patrick@stwcx.xyz>2016-06-24 15:22:21 -0500
commit3dbac6d88b8a9c8bc8587788694317834e3e5341 (patch)
treedd92687fab640c4e1fa53d7132565ad37213038a /meta-phosphor/common/recipes-connectivity
parente6797eef243cdfc37f647b787e4600b38229d664 (diff)
downloadtalos-openbmc-3dbac6d88b8a9c8bc8587788694317834e3e5341.tar.gz
talos-openbmc-3dbac6d88b8a9c8bc8587788694317834e3e5341.zip
openssl: run 'make depend'
The configure flags we have require openssl to be built with: make depend && make The current openssl.inc file only has 'make', so prepend a call to 'make depend'. Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Diffstat (limited to 'meta-phosphor/common/recipes-connectivity')
-rw-r--r--meta-phosphor/common/recipes-connectivity/openssl/openssl/Configure.patch15
-rw-r--r--meta-phosphor/common/recipes-connectivity/openssl/openssl_%.bbappend6
2 files changed, 21 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-connectivity/openssl/openssl/Configure.patch b/meta-phosphor/common/recipes-connectivity/openssl/openssl/Configure.patch
new file mode 100644
index 000000000..690301bf4
--- /dev/null
+++ b/meta-phosphor/common/recipes-connectivity/openssl/openssl/Configure.patch
@@ -0,0 +1,15 @@
+diff --git a/Configure.bak b/Configure
+index c98107a..320cf2c 100755
+--- a/Configure.bak
++++ b/Configure
+@@ -1723,8 +1723,8 @@ while (<IN>)
+ s/^CC=.*$/CC= $cc/;
+ s/^AR=\s*ar/AR= $ar/;
+ s/^RANLIB=.*/RANLIB= $ranlib/;
+- s/^MAKEDEPPROG=.*$/MAKEDEPPROG= $cc/ if $cc eq "gcc";
+- s/^MAKEDEPPROG=.*$/MAKEDEPPROG= $cc/ if $ecc eq "gcc" || $ecc eq "clang";
++ s/^MAKEDEPPROG=.*$/MAKEDEPPROG= $cc/; # if $cc eq "gcc";
++ #s/^MAKEDEPPROG=.*$/MAKEDEPPROG= $cc/ if $ecc eq "gcc" || $ecc eq "clang";
+ }
+ s/^CFLAG=.*$/CFLAG= $cflags/;
+ s/^DEPFLAG=.*$/DEPFLAG=$depflags/;
diff --git a/meta-phosphor/common/recipes-connectivity/openssl/openssl_%.bbappend b/meta-phosphor/common/recipes-connectivity/openssl/openssl_%.bbappend
index a18a55228..5816aef72 100644
--- a/meta-phosphor/common/recipes-connectivity/openssl/openssl_%.bbappend
+++ b/meta-phosphor/common/recipes-connectivity/openssl/openssl_%.bbappend
@@ -1,3 +1,5 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+SRC_URI_append = "file://Configure.patch"
# General config settings.
EXTRA_OECONF_append = " shared no-hw no-err no-psk no-srp no-engines "
@@ -9,3 +11,7 @@ EXTRA_OECONF_append = " no-ssl2 no-ssl3 "
EXTRA_OECONF_append = " no-idea no-md2 no-mdc2 no-rc5 no-md4 \
no-ripemd160 no-rmd160 no-whirlpool no-sha0 no-camellia \
no-rc2 no-rc4 no-bf no-cast no-seed no-gost "
+
+do_configure_append() {
+ oe_runmake depend
+}
OpenPOWER on IntegriCloud