summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common/recipes-bsp/u-boot/u-boot-mkimage_2016.05.bb
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2016-06-13 10:54:37 -0500
committerGitHub <noreply@github.com>2016-06-13 10:54:37 -0500
commit6b975db45f2331468058b9984f6c408f6ec8a033 (patch)
tree131b22e327d8ba01ff28596b860f7ffd5d52bd97 /meta-phosphor/common/recipes-bsp/u-boot/u-boot-mkimage_2016.05.bb
parentb0e84fc9fb207fc000bd024634759c7ce9a0a776 (diff)
parentb62efc0d787877d77cd53e0361cba95afab2d78c (diff)
downloadtalos-openbmc-6b975db45f2331468058b9984f6c408f6ec8a033.tar.gz
talos-openbmc-6b975db45f2331468058b9984f6c408f6ec8a033.zip
Merge pull request #312 from bradbishop/ast2500
initial ast2500 stubs
Diffstat (limited to 'meta-phosphor/common/recipes-bsp/u-boot/u-boot-mkimage_2016.05.bb')
-rw-r--r--meta-phosphor/common/recipes-bsp/u-boot/u-boot-mkimage_2016.05.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-bsp/u-boot/u-boot-mkimage_2016.05.bb b/meta-phosphor/common/recipes-bsp/u-boot/u-boot-mkimage_2016.05.bb
new file mode 100644
index 000000000..27ed1314b
--- /dev/null
+++ b/meta-phosphor/common/recipes-bsp/u-boot/u-boot-mkimage_2016.05.bb
@@ -0,0 +1,29 @@
+SUMMARY = "U-Boot bootloader image creation tool"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6"
+SECTION = "bootloader"
+
+DEPENDS = "openssl"
+
+SRCREV = "47441cc36bb8e919a066837e4d7c5a8a1c475da4"
+UBRANCH = "v2016.05-ast2500"
+SRC_URI = "git://git@github.com/openbmc/u-boot.git;branch=${UBRANCH};protocol=https"
+
+PV = "v2016.05+git${SRCPV}"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OEMAKE = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" STRIP=true V=1'
+
+do_compile () {
+ oe_runmake sandbox_defconfig
+ oe_runmake cross_tools NO_SDL=1
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage
+ ln -sf uboot-mkimage ${D}${bindir}/mkimage
+}
+
+BBCLASSEXTEND = "native nativesdk"
OpenPOWER on IntegriCloud