summaryrefslogtreecommitdiffstats
path: root/meta-openpower
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-03-22 21:41:12 -0400
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-03-26 16:46:21 -0400
commitad06047d8c4db62a3d1b4af6a32bb11c2c7147ce (patch)
tree1c5e31ad442a4462f9b3dbbb7e008fabff53455f /meta-openpower
parente24a3fd2dfe1c687a4efc418d7fee3baf5fec283 (diff)
downloadtalos-openbmc-ad06047d8c4db62a3d1b4af6a32bb11c2c7147ce.tar.gz
talos-openbmc-ad06047d8c4db62a3d1b4af6a32bb11c2c7147ce.zip
meta-openpower: Fix explicit dependencies antipattern
Out of the box bitbake examines built applications, automatically adds runtime dependencies and thus ensures any library packages dependencies are automatically added to images, sdks, etc. There is no need to list them explicitly in a recipe. Dependencies change over time, and listing them explicitly is likely prone to errors - the net effect being unnecessary shared library packages being installed into images. Consult https://www.yoctoproject.org/docs/latest/mega-manual/mega-manual.html#var-RDEPENDS for information on when to use explicit runtime dependencies. (From meta-openpower rev: 42fbcf6040860dc6b0b553febeabedd241f22a27) Change-Id: If56c264d3807f604ae8ba9c948095ba61093285d Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openpower')
-rw-r--r--meta-openpower/recipes-phosphor/debug/openpower-debug-collector_git.bb4
-rw-r--r--meta-openpower/recipes-phosphor/flash/openpower-software-manager_git.bb3
-rw-r--r--meta-openpower/recipes-phosphor/host/op-proc-control_git.bb6
-rw-r--r--meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem_git.bb7
-rw-r--r--meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb7
-rw-r--r--meta-openpower/recipes-phosphor/vpd/openpower-fru-vpd_git.bb5
6 files changed, 0 insertions, 32 deletions
diff --git a/meta-openpower/recipes-phosphor/debug/openpower-debug-collector_git.bb b/meta-openpower/recipes-phosphor/debug/openpower-debug-collector_git.bb
index 9127273d1..d79a01c5e 100644
--- a/meta-openpower/recipes-phosphor/debug/openpower-debug-collector_git.bb
+++ b/meta-openpower/recipes-phosphor/debug/openpower-debug-collector_git.bb
@@ -17,10 +17,6 @@ DEPENDS += " \
autoconf-archive-native \
sdbus++-native \
"
-RDEPENDS_${PN} += " \
- phosphor-logging \
- "
-
S = "${WORKDIR}/git"
# This provides below 2 applications that are called into in case
diff --git a/meta-openpower/recipes-phosphor/flash/openpower-software-manager_git.bb b/meta-openpower/recipes-phosphor/flash/openpower-software-manager_git.bb
index adbe2f843..c40a21b95 100644
--- a/meta-openpower/recipes-phosphor/flash/openpower-software-manager_git.bb
+++ b/meta-openpower/recipes-phosphor/flash/openpower-software-manager_git.bb
@@ -28,9 +28,6 @@ DEPENDS += " \
RDEPENDS_${PN} += " \
mtd-utils-ubifs \
- phosphor-dbus-interfaces \
- phosphor-logging \
- sdbusplus \
virtual-obmc-image-manager \
"
diff --git a/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb b/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
index 4251ba4e0..6f19e39a1 100644
--- a/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
+++ b/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
@@ -20,12 +20,6 @@ DEPENDS += " \
openpower-dbus-interfaces \
"
-RDEPENDS_${PN} += " \
- phosphor-logging \
- phosphor-dbus-interfaces \
- openpower-dbus-interfaces \
- "
-
TEMPLATE = "pcie-poweroff@.service"
INSTANCE_FORMAT = "pcie-poweroff@{}.service"
INSTANCES = "${@compose_list(d, 'INSTANCE_FORMAT', 'OBMC_CHASSIS_INSTANCES')}"
diff --git a/meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem_git.bb b/meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem_git.bb
index e4d9b04fa..711b7e6a3 100644
--- a/meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem_git.bb
+++ b/meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem_git.bb
@@ -20,13 +20,6 @@ DEPENDS += "openpower-dbus-interfaces openpower-dbus-interfaces-native"
DEPENDS += "sdbus++-native"
DEPENDS += "virtual/phosphor-ipmi-inventory-sel"
-RDEPENDS_${PN} += " \
- sdbusplus \
- phosphor-logging \
- openpower-dbus-interfaces \
- phosphor-dbus-interfaces \
- "
-
TARGET_CFLAGS += "-fpic"
HOSTIPMI_PROVIDER_LIBRARY += "liboemhandler.so"
diff --git a/meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb b/meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb
index fcf1263a2..49adbb5b1 100644
--- a/meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb
+++ b/meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb
@@ -36,13 +36,6 @@ DEPENDS += " \
systemd \
"
-RDEPENDS_${PN} += " \
- sdbusplus \
- phosphor-logging \
- openpower-dbus-interfaces \
- phosphor-dbus-interfaces \
- "
-
EXTRA_OECONF = " \
YAML_PATH=${STAGING_DATADIR_NATIVE}/${PN} \
PS_DERATING_FACTOR=${POWER_SUPPLY_DERATING_FACTOR} \
diff --git a/meta-openpower/recipes-phosphor/vpd/openpower-fru-vpd_git.bb b/meta-openpower/recipes-phosphor/vpd/openpower-fru-vpd_git.bb
index c9d3b66c0..a1b7026a8 100644
--- a/meta-openpower/recipes-phosphor/vpd/openpower-fru-vpd_git.bb
+++ b/meta-openpower/recipes-phosphor/vpd/openpower-fru-vpd_git.bb
@@ -23,11 +23,6 @@ DEPENDS += " \
autoconf-archive-native \
"
-RDEPENDS_${PN} += " \
- sdbusplus \
- phosphor-logging \
- "
-
SYSTEMD_SERVICE_${PN} += "op-vpd-parser.service"
S = "${WORKDIR}/git"
OpenPOWER on IntegriCloud