summaryrefslogtreecommitdiffstats
path: root/meta-openpower
diff options
context:
space:
mode:
authorAndrew Geissler <openbmcbump-github@yahoo.com>2018-11-20 03:20:12 +0000
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-11-26 08:31:02 -0500
commit643013c73f08959a1a4aea146d4c07cf03decb2f (patch)
tree5d7505d57733db98b562f1d3a79e11b4595992b4 /meta-openpower
parent44793e03faa3fd825776017a4eb7f0da9b722ebf (diff)
downloadtalos-openbmc-643013c73f08959a1a4aea146d4c07cf03decb2f.tar.gz
talos-openbmc-643013c73f08959a1a4aea146d4c07cf03decb2f.zip
Update recipe to include pcie-poweroff service
Updated recipe to incorporate service file added in [1]. These changes add a p9 PCIE poweroff workaround in openpower-proc-control. The new services will use this workaround before cutting power during a chassisoff. [1] https://gerrit.openbmc-project.xyz/#/c/openbmc/openpower-proc-control/+/15192 (From meta-openpower rev: 179b68f566e0cc88c4b93910e9a6ae3a38baa3ae) Change-Id: I7eb4ef37343d518bb3757551605921322f7c8caf Signed-off-by: Anthony Wilson <wilsonan@us.ibm.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openpower')
-rw-r--r--meta-openpower/recipes-phosphor/host/op-proc-control_git.bb11
1 files changed, 9 insertions, 2 deletions
diff --git a/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb b/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
index 36f4c7a0f..f78644278 100644
--- a/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
+++ b/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
@@ -7,10 +7,11 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
S = "${WORKDIR}/git"
-inherit autotools pkgconfig pythonnative
+inherit autotools obmc-phosphor-utils pkgconfig pythonnative
+inherit systemd
SRC_URI += "git://github.com/openbmc/openpower-proc-control"
-SRCREV = "5970484133ac208bd3675697ac120901ea6654a7"
+SRCREV = "171fbdf683976ee54d1aa13745523b355d751ff5"
DEPENDS += " \
autoconf-archive-native \
@@ -24,3 +25,9 @@ RDEPENDS_${PN} += " \
phosphor-dbus-interfaces \
openpower-dbus-interfaces \
"
+
+TEMPLATE = "pcie-poweroff@.service"
+INSTANCE_FORMAT = "pcie-poweroff@{}.service"
+INSTANCES = "${@compose_list(d, 'INSTANCE_FORMAT', 'OBMC_CHASSIS_INSTANCES')}"
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE_${PN} = "${TEMPLATE} ${INSTANCES}"
OpenPOWER on IntegriCloud