summaryrefslogtreecommitdiffstats
path: root/meta-openpower/recipes-phosphor
diff options
context:
space:
mode:
authorRaptor Engineering Development Team <support@raptorengineering.com>2020-02-16 20:56:49 +0000
committerRaptor Engineering Development Team <support@raptorengineering.com>2020-02-17 12:35:13 +0000
commitbc0ca9464ea7b062ac9432d9d03e72acae2078d0 (patch)
treec248dd645dba9adcebe913dffec58d32463d0e20 /meta-openpower/recipes-phosphor
parent8e564b2fc9ff9ea64fd4362faf65fa550500f279 (diff)
downloadtalos-openbmc-bc0ca9464ea7b062ac9432d9d03e72acae2078d0.tar.gz
talos-openbmc-bc0ca9464ea7b062ac9432d9d03e72acae2078d0.zip
Switch fan controls from RCS PID to upstream swampid daemon
WARNING: HIC SUNT DRAGONES! ***WORK IN PROGRESS*** Basic functionality has been hacked in, but this should NOT be relied on in production environments without proper fixes originated from / merged into upstream OpenBMC.
Diffstat (limited to 'meta-openpower/recipes-phosphor')
-rwxr-xr-xmeta-openpower/recipes-phosphor/occ/openpower-occ-control/occ-active.sh4
-rw-r--r--meta-openpower/recipes-phosphor/packagegroups/packagegroup-op-apps.bb1
2 files changed, 2 insertions, 3 deletions
diff --git a/meta-openpower/recipes-phosphor/occ/openpower-occ-control/occ-active.sh b/meta-openpower/recipes-phosphor/occ/openpower-occ-control/occ-active.sh
index ffd1e6bd0..edb35b311 100755
--- a/meta-openpower/recipes-phosphor/occ/openpower-occ-control/occ-active.sh
+++ b/meta-openpower/recipes-phosphor/occ/openpower-occ-control/occ-active.sh
@@ -62,7 +62,7 @@ busctl tree $OCC_CONTROL_SERVICE --list | grep occ | xargs -r -n1 -I{} \
if [ "$value" == "true" ]; then
# Wait 5 seconds before restarting fan controller
sleep 5
- systemctl restart phosphor-fan-control@0.service
+ systemctl restart phosphor-pid-control.service
else
# Unbind all OCC drivers to avoid bus contention on next IPL
echo occ-hwmon.1 > /sys/bus/platform/drivers/occ-hwmon/unbind || true
@@ -144,7 +144,7 @@ if [ "$1" == "watchdog" ]; then
sleep 5
# Restart fan controller
- systemctl restart phosphor-fan-control@0.service
+ systemctl restart phosphor-pid-control.service
fi
done
fi
diff --git a/meta-openpower/recipes-phosphor/packagegroups/packagegroup-op-apps.bb b/meta-openpower/recipes-phosphor/packagegroups/packagegroup-op-apps.bb
index 1ae123a3a..636c88b10 100644
--- a/meta-openpower/recipes-phosphor/packagegroups/packagegroup-op-apps.bb
+++ b/meta-openpower/recipes-phosphor/packagegroups/packagegroup-op-apps.bb
@@ -37,7 +37,6 @@ RDEPENDS_${PN}-chassis += "${@mf_enabled(d, 'p9-cfam-override', 'p9-cfam-overrid
SUMMARY_${PN}-fans = "OpenPOWER Fans"
RDEPENDS_${PN}-fans = " \
- obmc-control-fan \
"
SUMMARY_${PN}-flash = "OpenPOWER Flash"
OpenPOWER on IntegriCloud