summaryrefslogtreecommitdiffstats
path: root/meta-openembedded
diff options
context:
space:
mode:
authorJames Feist <james.feist@linux.intel.com>2018-10-11 13:47:04 -0700
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-10-16 02:12:45 +0000
commitcb07cdfbce2ede5e4f9563cdb818056bcfc64b86 (patch)
tree405b938c8cf475eaac86d83de7f864381898717b /meta-openembedded
parente332299438328f0f0b6813c7fe6d7a6c628d5ff5 (diff)
downloadtalos-openbmc-cb07cdfbce2ede5e4f9563cdb818056bcfc64b86.tar.gz
talos-openbmc-cb07cdfbce2ede5e4f9563cdb818056bcfc64b86.zip
nlohmann-json: Add symlink to json.hpp and update to 3.3.0
nlohmann-json has examples in their repo that refer to the header as json.hpp directly, as such many packages that require nlohmann-json expect json.hpp and not nlohmann/json.hpp as the cmake file installs. Create symlink so that access is available by either option. Also update to release 3.3.0. (From meta-openembedded rev: 69e5fa1485aa58ad1d664070b0d9e4db413fdd62) Change-Id: Ie43a76e16eb1d1a107e090d544937d6465719d6c Signed-off-by: James Feist <james.feist@linux.intel.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openembedded')
-rw-r--r--meta-openembedded/meta-oe/recipes-devtools/nlohmann-json/nlohmann-json_git.bb10
1 files changed, 8 insertions, 2 deletions
diff --git a/meta-openembedded/meta-oe/recipes-devtools/nlohmann-json/nlohmann-json_git.bb b/meta-openembedded/meta-oe/recipes-devtools/nlohmann-json/nlohmann-json_git.bb
index a89b659ae..65e49bc95 100644
--- a/meta-openembedded/meta-oe/recipes-devtools/nlohmann-json/nlohmann-json_git.bb
+++ b/meta-openembedded/meta-oe/recipes-devtools/nlohmann-json/nlohmann-json_git.bb
@@ -6,9 +6,9 @@ LIC_FILES_CHKSUM = "file://LICENSE.MIT;md5=9a8ae1c2d606c432a2aa2e2de15be22a"
SRC_URI = "git://github.com/nlohmann/json.git"
-PV = "3.2.0+git${SRCPV}"
+PV = "3.3.0+git${SRCPV}"
-SRCREV = "8c20571136f2d5351b379a06ad6591bd980880fe"
+SRCREV = "aafad2be1f3cd259a1e79d2f6fcf267d1ede9ec7"
S = "${WORKDIR}/git"
@@ -21,3 +21,9 @@ EXTRA_OECMAKE += "-DJSON_BuildTests=OFF"
RDEPENDS_${PN}-dev = ""
BBCLASSEXTEND = "native nativesdk"
+
+# other packages commonly reference the file directly as "json.hpp"
+# create symlink to allow this usage
+do_install_append() {
+ ln -s nlohmann/json.hpp ${D}${includedir}/json.hpp
+}
OpenPOWER on IntegriCloud