summaryrefslogtreecommitdiffstats
path: root/meta-openembedded/meta-networking/recipes-daemons
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2019-02-22 16:03:50 -0600
committerAndrew Geissler <geissonator@yahoo.com>2019-02-22 16:05:07 -0600
commit1548c07ccf17a3a7a4fad7f31fb62d117bcb674f (patch)
treedc38b5d3eba36dab80ecd70556e05f4fae917c12 /meta-openembedded/meta-networking/recipes-daemons
parent8704effb21a9aac3e4c97d234149887b6acfa941 (diff)
downloadtalos-openbmc-1548c07ccf17a3a7a4fad7f31fb62d117bcb674f.tar.gz
talos-openbmc-1548c07ccf17a3a7a4fad7f31fb62d117bcb674f.zip
meta-openembedded: refresh thud: cca27b5ea7..6ef9657068
Update meta-openembedded to thud HEAD. Alexander Kanavin (2): packagegroup-meta-oe: drop ptest packages that do not exist packagegroup-meta-oe: rename the group that contains ptest packages Andrea Adami (4): klibc: fix build for mipsel and mips64el with security flags enabled waf-cross-answers: Add cross-answers-mips64el.txt kexec-tools-klibc: fix build for mipsel and mips64el samba: fix build on qemumips64 with musl Andreas Müller (1): libgit2: Fix install for multilib Armin Kuster (1): wireshark: update to 2.6.6 Craig McQueen (1): python3-multidict: Workaround for broken make clean Eduardas Meile (1): toybox: fix to use "usrmerge" distro feature properly Haiqing Bai (1): ptpd: fixed the issue of ptpd2 daemon takes 100% CPU Hong Liu (1): wireshark: upgrade to 2.6.5 Hongxu Jia (1): python-pyparted/python3-pyparted: drop incorrect and redundant PV Kai Kang (1): net-snmp: inherit ptest Khem Raj (16): xscreensaver: Define consistent app-defaults dir a2jmidid: Define own do_configure bpftool: don't build under musl packagegroup-meta-oe: Remove arch specific packages as needed packagegroup-meta-oe: Remove packages which don't build for musl modemmanager: Fix build with clang klibc: Fix build with clang srecord: GPL-3.0 and LGPL-3.0 is correct license packagegroup-meta-oe: Exclude unbuildable packages on mips64 packagegroup-meta-oe: Exclude android-tools breakpad on ppc packagegroup-meta-oe: Remove unbuildable packages on risc-v from rdep mpv: Disable lua on mips/aarch64 luajit: Disable for mips n64/n32 hosts licenses: Add Arphic-Public-License text nmap: Fix build with clang8/musl/libc++ mozjs: Fix symbol visibility with clang/libc++ Marc Ferland (1): networkmanager: fix QA issue when using modemmanager and ppp in PACKAGECONFIG Martin Jansa (1): open-vm-tools: fix indentation and drop FILES_${PN}-dbg Mingli Yu (1): vim: improve reproducibility Niko Mauno (7): python-pygobject: Fix invalid install path python-pygobject: Drop redundant PYTHON* refs python-pygobject: Drop redundant dependencies python-pygobject: Only check for even upstream versions python-pygobject: Remove duplication in inherit python-pygobject: Fix style issue python-pygobject: Tune remove operation Otavio Salvador (2): mozjs: Avoid use of X11 from host when X11 is disabled postgresql: Allow successful run of postgresql-setup Primoz Fiser (1): sedutil: fix compile errors on big endian architectures Scott Ellis (2): nmap: Fix typo in pcre PACKAGECONFIG nmap: Include additional FILES path for certs leimaohui (2): mraa: To file do_package error in multilib. makedumpfile: Add aarch64 into COMPATIBLE_HOST. thc (1): fix networkmanager apppend Change-Id: I979f5ccefeec364f27df10888ae6258923a30659 Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-openembedded/meta-networking/recipes-daemons')
-rw-r--r--meta-openembedded/meta-networking/recipes-daemons/ptpd/ptpd/Fixed-100-CPU-using-issue-by-adding-minimum-POSIX-ti.patch68
-rw-r--r--meta-openembedded/meta-networking/recipes-daemons/ptpd/ptpd_2.3.1.bb1
2 files changed, 69 insertions, 0 deletions
diff --git a/meta-openembedded/meta-networking/recipes-daemons/ptpd/ptpd/Fixed-100-CPU-using-issue-by-adding-minimum-POSIX-ti.patch b/meta-openembedded/meta-networking/recipes-daemons/ptpd/ptpd/Fixed-100-CPU-using-issue-by-adding-minimum-POSIX-ti.patch
new file mode 100644
index 000000000..1d2a5368c
--- /dev/null
+++ b/meta-openembedded/meta-networking/recipes-daemons/ptpd/ptpd/Fixed-100-CPU-using-issue-by-adding-minimum-POSIX-ti.patch
@@ -0,0 +1,68 @@
+From e00d3f52ccc6496a60992ac5a9d771b1d067eceb Mon Sep 17 00:00:00 2001
+From: Haiqing Bai <Haiqing.Bai@windriver.com>
+Date: Thu, 22 Nov 2018 08:42:48 +0000
+Subject: [PATCH] Fixed 100% CPU using issue by adding minimum POSIX timer
+ interval
+
+Added minimum POSIX timer interval to prevent from timers firing
+to quickly for the process to handle, resulting in 100% CPU and
+endless signal queue.
+
+Upstream-status: Backport
+[From commit 1f0baae98a7b23e85f2bfd8f5de64795421c270e:
+ - critical: added minimum POSIX timer interval to prevent from
+ timers firing to quickly for the process to handle,
+ resulting in 100% CPU and endless signal queue]
+
+Signed-off-by: Haiqing Bai <Haiqing.Bai@windriver.com>
+---
+ src/dep/eventtimer.h | 3 ++-
+ src/dep/eventtimer_itimer.c | 2 +-
+ src/dep/eventtimer_posix.c | 4 ++++
+ 3 files changed, 7 insertions(+), 2 deletions(-)
+
+diff --git a/src/dep/eventtimer.h b/src/dep/eventtimer.h
+index 64e483a..0a21318 100644
+--- a/src/dep/eventtimer.h
++++ b/src/dep/eventtimer.h
+@@ -30,7 +30,8 @@
+ * IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+ */
+
+-#define EVENTTIMER_MAX_DESC 20
++#define EVENTTIMER_MAX_DESC 20
++#define EVENTTIMER_MIN_INTERVAL_US 250 /* 4000/sec */
+
+ typedef struct EventTimer EventTimer;
+
+diff --git a/src/dep/eventtimer_itimer.c b/src/dep/eventtimer_itimer.c
+index cf3c6db..3bb7ec6 100644
+--- a/src/dep/eventtimer_itimer.c
++++ b/src/dep/eventtimer_itimer.c
+@@ -53,7 +53,7 @@
+
+ #include "../ptpd.h"
+
+-#define US_TIMER_INTERVAL (62500)
++#define US_TIMER_INTERVAL (31250)
+
+ static volatile unsigned int elapsed;
+
+diff --git a/src/dep/eventtimer_posix.c b/src/dep/eventtimer_posix.c
+index 637eef3..f4a702d 100644
+--- a/src/dep/eventtimer_posix.c
++++ b/src/dep/eventtimer_posix.c
+@@ -100,6 +100,10 @@ eventTimerStart_posix(EventTimer *timer, double interval)
+ ts.tv_sec = interval;
+ ts.tv_nsec = (interval - ts.tv_sec) * 1E9;
+
++ if(!ts.tv_sec && ts.tv_nsec < EVENTTIMER_MIN_INTERVAL_US * 1000) {
++ ts.tv_nsec = EVENTTIMER_MIN_INTERVAL_US * 1000;
++ }
++
+ DBGV("Timer %s start requested at %d.%4d sec interval\n", timer->id, ts.tv_sec, ts.tv_nsec);
+
+ its.it_interval = ts;
+--
+2.11.0
+
diff --git a/meta-openembedded/meta-networking/recipes-daemons/ptpd/ptpd_2.3.1.bb b/meta-openembedded/meta-networking/recipes-daemons/ptpd/ptpd_2.3.1.bb
index e13619320..58625c809 100644
--- a/meta-openembedded/meta-networking/recipes-daemons/ptpd/ptpd_2.3.1.bb
+++ b/meta-openembedded/meta-networking/recipes-daemons/ptpd/ptpd_2.3.1.bb
@@ -23,6 +23,7 @@ def get_sub(d):
SRC_URI = "http://downloads.sourceforge.net/project/ptpd/ptpd/${@get_sub(d)}/ptpd-${PV}.tar.gz \
file://ptpd-use-pkgconfig.patch \
+ file://Fixed-100-CPU-using-issue-by-adding-minimum-POSIX-ti.patch \
file://ptpd.service \
file://ptpd.conf \
"
OpenPOWER on IntegriCloud