summaryrefslogtreecommitdiffstats
path: root/meta-openbmc-machines
diff options
context:
space:
mode:
authorBrandon Wyman <bjwyman@gmail.com>2017-06-09 17:50:42 -0500
committerPatrick Williams <patrick@stwcx.xyz>2017-06-12 12:18:24 +0000
commit5b42b7457a53a874a2f1517cd5a3d1b83842260c (patch)
tree57b6c80fdee3d73064af3fe6b13cb93b237284a8 /meta-openbmc-machines
parentc84d4131a092b40db534eecce77f4d1e9e589032 (diff)
downloadtalos-openbmc-5b42b7457a53a874a2f1517cd5a3d1b83842260c.tar.gz
talos-openbmc-5b42b7457a53a874a2f1517cd5a3d1b83842260c.zip
Fix up recipes to address missing fan apps
Change to use the "softer" default value for PACKAGECONFIG by default. Change to append extra paths in bbappend for Witherspoon. Fix up/change some names in bbappend file for Witherspoon. Resolves openbmc/openbmc#1765 Change-Id: I316e1e857b008ccd67e922698ee7e0a9c5d222fc Signed-off-by: Brandon Wyman <bjwyman@gmail.com>
Diffstat (limited to 'meta-openbmc-machines')
-rw-r--r--meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan%.bbappend19
-rw-r--r--meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan%/phosphor-cooling-type@.service2
2 files changed, 11 insertions, 10 deletions
diff --git a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan%.bbappend b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan%.bbappend
index 48bad3d14..b9fc6631b 100644
--- a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan%.bbappend
+++ b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan%.bbappend
@@ -1,23 +1,24 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-
-PACKAGECONFIG += "cooling-type"
+FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
# Package configuration
FAN_PACKAGES += " \
phosphor-cooling-type \
"
+
+PACKAGECONFIG += "cooling-type"
+
RDEPENDS_phosphor-cooling-type += "libevdev"
-COOLING_TMPL = "phosphor-cooling-type@.service"
-COOLING_INSTFMT = "phosphor-cooling-type@{0}.service"
+TMPL_COOLING = "phosphor-cooling-type@.service"
+INSTFMT_COOLING = "phosphor-cooling-type@{0}.service"
COOLING_TGT = "${SYSTEMD_DEFAULT_TARGET}"
-COOLING_FMT = "../${COOLING_TMPL}:${COOLING_TGT}.requires/${COOLING_INSTFMT}"
+FMT_COOLING = "../${TMPL_COOLING}:${COOLING_TGT}.requires/${INSTFMT_COOLING}"
FILES_phosphor-cooling-type = "${sbindir}/phosphor-cooling-type"
-SYSTEMD_SERVICE_phosphor-cooling-type += "${COOLING_TMPL}"
-SYSTEMD_LINK_phosphor-cooling-type += "${@compose_list(d, 'COOLING_FMT', 'OBMC_CHASSIS_INSTANCES')}"
+SYSTEMD_SERVICE_phosphor-cooling-type += "${TMPL_COOLING}"
+SYSTEMD_LINK_phosphor-cooling-type += "${@compose_list(d, 'FMT_COOLING', 'OBMC_CHASSIS_INSTANCES')}"
COOLING_ENV_FMT = "obmc/phosphor-fan/phosphor-cooling-type-{0}.conf"
-SYSTEMD_ENVIRONMENT_FILE_phosphor-chassis-cooling-type += "${@compose_list(d, 'COOLING_ENV_FMT', 'OBMC_CHASSIS_INSTANCES')}"
+SYSTEMD_ENVIRONMENT_FILE_phosphor-cooling-type += "${@compose_list(d, 'COOLING_ENV_FMT', 'OBMC_CHASSIS_INSTANCES')}"
diff --git a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan%/phosphor-cooling-type@.service b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan%/phosphor-cooling-type@.service
index 62fd43804..850a8836a 100644
--- a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan%/phosphor-cooling-type@.service
+++ b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan%/phosphor-cooling-type@.service
@@ -5,7 +5,7 @@ After=mapper-wait@-xyz-openbmc_project-inventory.service
ConditionPathExists={envfiledir}/phosphor-cooling-type-%i.conf
[Service]
-EnvironmentFile={envfiledir}/phosphor-cooling-type-%i.conf
+EnvironmentFile={envfiledir}/obmc/phosphor-fan/phosphor-cooling-type-%i.conf
ExecStart={sbindir}/phosphor-cooling-type ${{OBJPATH}} ${{AIR}} ${{WATER}} ${{DEVICE}} ${{CODE}}
[Install]
OpenPOWER on IntegriCloud