summaryrefslogtreecommitdiffstats
path: root/meta-openbmc-machines
diff options
context:
space:
mode:
authorAdriana Kobylak <anoo@us.ibm.com>2017-06-02 09:22:40 -0500
committerPatrick Williams <patrick@stwcx.xyz>2017-06-03 13:09:10 +0000
commit2e950829cb80cbab14ef00186dd47515a8ee53db (patch)
treeb4711698d844508d5fcc7118b9fd66c12d38d133 /meta-openbmc-machines
parenta9dcb06b757fe0d476b630f0f9d84b2cb6ce08de (diff)
downloadtalos-openbmc-2e950829cb80cbab14ef00186dd47515a8ee53db.tar.gz
talos-openbmc-2e950829cb80cbab14ef00186dd47515a8ee53db.zip
openpower-software-manager: Recipe fixes
When the do_install block was added to add the script files, the binary from the git repository was no longer installed in the package. Replace with do_install_append. Also remove the duplicated source variable S. And reorder the recipe to make it cleaner. Closes openbmc/openbmc#1713 Change-Id: Iae814884a1b90dd15ea9ead010d4e26f22aa7ca1 Signed-off-by: Adriana Kobylak <anoo@us.ibm.com>
Diffstat (limited to 'meta-openbmc-machines')
-rw-r--r--meta-openbmc-machines/meta-openpower/common/recipes-phosphor/flash/openpower-software-manager.bb15
1 files changed, 8 insertions, 7 deletions
diff --git a/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/flash/openpower-software-manager.bb b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/flash/openpower-software-manager.bb
index 4c0f2e2e3..20710333f 100644
--- a/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/flash/openpower-software-manager.bb
+++ b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/flash/openpower-software-manager.bb
@@ -24,18 +24,24 @@ RDEPENDS_${PN} += " \
sdbusplus \
"
-S = "${WORKDIR}"
+S = "${WORKDIR}/git"
+
+SRC_URI += "git://github.com/openbmc/openpower-pnor-code-mgmt"
+
SRC_URI += " \
file://bios-ubiattach \
file://bios-ubiformat"
-do_install() {
+SRCREV = "5ba6b10e0b3622ceb920a07d1094af7607ae5dff"
+
+do_install_append() {
install -d ${D}${sbindir}
install -m 0755 ${WORKDIR}/bios-ubiattach ${D}${sbindir}/bios-ubiattach
install -m 0755 ${WORKDIR}/bios-ubiformat ${D}${sbindir}/bios-ubiformat
}
DBUS_SERVICE_${PN} += "org.open_power.Software.Host.Updater.service"
+
SYSTEMD_SERVICE_${PN} += " \
obmc-flash-bios-ubiattach.service \
obmc-flash-bios-ubimount@.service \
@@ -43,8 +49,3 @@ SYSTEMD_SERVICE_${PN} += " \
obmc-flash-bios-ubiumount-rw@.service \
obmc-flash-bios-squashfsmount@.service \
"
-
-SRC_URI += "git://github.com/openbmc/openpower-pnor-code-mgmt"
-SRCREV = "5ba6b10e0b3622ceb920a07d1094af7607ae5dff"
-
-S = "${WORKDIR}/git"
OpenPOWER on IntegriCloud