summaryrefslogtreecommitdiffstats
path: root/meta-openbmc-machines/meta-openpower
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2017-01-17 12:23:40 -0500
committerPatrick Williams <patrick@stwcx.xyz>2017-01-25 04:08:16 +0000
commite425d2ea5be21e11861f2963c9b7ca296df38a9b (patch)
tree72ac71282b88ff385602cabf04b4aa6da62d6f51 /meta-openbmc-machines/meta-openpower
parentd19c43d979f46a31a027f1b85d6220c6e3e19086 (diff)
downloadtalos-openbmc-e425d2ea5be21e11861f2963c9b7ca296df38a9b.tar.gz
talos-openbmc-e425d2ea5be21e11861f2963c9b7ca296df38a9b.zip
Phosphor IPMI FRU config stubs for most systems
Add native recipe stubs that (will) provide the the IPMI -> DBus inventory mapping for the Phosphor IPMI FRU provider. Change-Id: I21e76bc23ef1638ddcc318a179808521dea7f205 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openbmc-machines/meta-openpower')
-rw-r--r--meta-openbmc-machines/meta-openpower/meta-ibm/meta-firestone/conf/machine/firestone.conf2
-rw-r--r--meta-openbmc-machines/meta-openpower/meta-ibm/meta-firestone/recipes-phosphor/ipmi/firestone-ipmi-inventory-map.bb18
-rw-r--r--meta-openbmc-machines/meta-openpower/meta-ibm/meta-firestone/recipes-phosphor/ipmi/firestone-ipmi-inventory-map/config.yaml1
-rw-r--r--meta-openbmc-machines/meta-openpower/meta-ibm/meta-garrison/conf/machine/garrison.conf2
-rw-r--r--meta-openbmc-machines/meta-openpower/meta-ibm/meta-garrison/recipes-phosphor/ipmi/garrison-ipmi-inventory-map.bb18
-rw-r--r--meta-openbmc-machines/meta-openpower/meta-ibm/meta-garrison/recipes-phosphor/ipmi/garrison-ipmi-inventory-map/config.yaml1
-rw-r--r--meta-openbmc-machines/meta-openpower/meta-ibm/meta-palmetto/conf/machine/palmetto.conf1
-rw-r--r--meta-openbmc-machines/meta-openpower/meta-ibm/meta-palmetto/recipes-phosphor/ipmi/palmetto-ipmi-inventory-map.bb19
-rw-r--r--meta-openbmc-machines/meta-openpower/meta-ibm/meta-palmetto/recipes-phosphor/ipmi/palmetto-ipmi-inventory-map/config.yaml1
-rw-r--r--meta-openbmc-machines/meta-openpower/meta-ibm/meta-romulus/conf/machine/romulus.conf3
-rw-r--r--meta-openbmc-machines/meta-openpower/meta-ibm/meta-romulus/recipes-phosphor/ipmi/romulus-ipmi-inventory-map.bb15
-rw-r--r--meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/conf/machine/witherspoon.conf1
-rw-r--r--meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/witherspoon-ipmi-inventory-map.bb14
-rw-r--r--meta-openbmc-machines/meta-openpower/meta-rackspace/meta-barreleye/conf/machine/barreleye.conf2
-rw-r--r--meta-openbmc-machines/meta-openpower/meta-rackspace/meta-barreleye/recipes-phosphor/ipmi/barreleye-ipmi-inventory-map.bb19
-rw-r--r--meta-openbmc-machines/meta-openpower/meta-rackspace/meta-barreleye/recipes-phosphor/ipmi/barreleye-ipmi-inventory-map/config.yaml1
16 files changed, 117 insertions, 1 deletions
diff --git a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-firestone/conf/machine/firestone.conf b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-firestone/conf/machine/firestone.conf
index 3f790a5e4..97d0bc269 100644
--- a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-firestone/conf/machine/firestone.conf
+++ b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-firestone/conf/machine/firestone.conf
@@ -10,3 +10,5 @@ UBOOT_ENTRYPOINT = "0x40008000"
UBOOT_LOADADDRESS = "0x40008000"
FLASH_SIZE = "32768"
+
+PREFERRED_PROVIDER_virtual/phosphor-ipmi-fru-config = "firestone-ipmi-inventory-map"
diff --git a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-firestone/recipes-phosphor/ipmi/firestone-ipmi-inventory-map.bb b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-firestone/recipes-phosphor/ipmi/firestone-ipmi-inventory-map.bb
new file mode 100644
index 000000000..52ff03e79
--- /dev/null
+++ b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-firestone/recipes-phosphor/ipmi/firestone-ipmi-inventory-map.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Firestone IPMI to DBus Inventory mapping."
+PR = "r1"
+
+inherit native
+inherit obmc-phosphor-license
+
+SRC_URI += "file://config.yaml"
+
+PROVIDES += "virtual/phosphor-ipmi-fru-config"
+
+S = "${WORKDIR}"
+
+do_install() {
+ DEST=${D}${datadir}/phosphor-ipmi-fru
+
+ install -d ${DEST}
+ install config.yaml ${DEST}
+}
diff --git a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-firestone/recipes-phosphor/ipmi/firestone-ipmi-inventory-map/config.yaml b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-firestone/recipes-phosphor/ipmi/firestone-ipmi-inventory-map/config.yaml
new file mode 100644
index 000000000..b3459a9eb
--- /dev/null
+++ b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-firestone/recipes-phosphor/ipmi/firestone-ipmi-inventory-map/config.yaml
@@ -0,0 +1 @@
+# This file is a stub.
diff --git a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-garrison/conf/machine/garrison.conf b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-garrison/conf/machine/garrison.conf
index 3a6d7a194..5653e5bde 100644
--- a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-garrison/conf/machine/garrison.conf
+++ b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-garrison/conf/machine/garrison.conf
@@ -10,3 +10,5 @@ UBOOT_ENTRYPOINT = "0x40008000"
UBOOT_LOADADDRESS = "0x40008000"
FLASH_SIZE = "32768"
+
+PREFERRED_PROVIDER_virtual/phosphor-ipmi-fru-config = "garrison-ipmi-inventory-map"
diff --git a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-garrison/recipes-phosphor/ipmi/garrison-ipmi-inventory-map.bb b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-garrison/recipes-phosphor/ipmi/garrison-ipmi-inventory-map.bb
new file mode 100644
index 000000000..05a622fce
--- /dev/null
+++ b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-garrison/recipes-phosphor/ipmi/garrison-ipmi-inventory-map.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Garrison IPMI to DBus Inventory mapping."
+PR = "r1"
+
+inherit native
+inherit obmc-phosphor-license
+
+SRC_URI += "file://config.yaml"
+
+PROVIDES += "virtual/phosphor-ipmi-fru-config"
+
+S = "${WORKDIR}"
+
+do_install() {
+ DEST=${D}${datadir}/phosphor-ipmi-fru
+
+ install -d ${DEST}
+ install config.yaml ${DEST}
+}
diff --git a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-garrison/recipes-phosphor/ipmi/garrison-ipmi-inventory-map/config.yaml b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-garrison/recipes-phosphor/ipmi/garrison-ipmi-inventory-map/config.yaml
new file mode 100644
index 000000000..b3459a9eb
--- /dev/null
+++ b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-garrison/recipes-phosphor/ipmi/garrison-ipmi-inventory-map/config.yaml
@@ -0,0 +1 @@
+# This file is a stub.
diff --git a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-palmetto/conf/machine/palmetto.conf b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-palmetto/conf/machine/palmetto.conf
index 9c60801e2..20cd7833f 100644
--- a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-palmetto/conf/machine/palmetto.conf
+++ b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-palmetto/conf/machine/palmetto.conf
@@ -15,3 +15,4 @@ PHOSPHOR_MRW_URI = "git://github.com/open-power/palmetto-xml"
PHOSPHOR_MRW_REV = "82818682f2c2009c30d700df6d5f8897a3096e4f"
PREFERRED_PROVIDER_virtual/obmc-inventory-data = "obmc-inventory"
+PREFERRED_PROVIDER_virtual/phosphor-ipmi-fru-config = "palmetto-ipmi-inventory-map"
diff --git a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-palmetto/recipes-phosphor/ipmi/palmetto-ipmi-inventory-map.bb b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-palmetto/recipes-phosphor/ipmi/palmetto-ipmi-inventory-map.bb
new file mode 100644
index 000000000..b9e1fcb6b
--- /dev/null
+++ b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-palmetto/recipes-phosphor/ipmi/palmetto-ipmi-inventory-map.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Palmetto IPMI to DBus Inventory mapping."
+PR = "r1"
+
+inherit native
+inherit obmc-phosphor-license
+
+SRC_URI += "file://config.yaml"
+
+PROVIDES += "virtual/phosphor-ipmi-fru-config"
+
+S = "${WORKDIR}"
+
+do_install() {
+ DEST=${D}${datadir}/phosphor-ipmi-fru
+
+ install -d ${DEST}
+ install config.yaml ${DEST}
+}
+
diff --git a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-palmetto/recipes-phosphor/ipmi/palmetto-ipmi-inventory-map/config.yaml b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-palmetto/recipes-phosphor/ipmi/palmetto-ipmi-inventory-map/config.yaml
new file mode 100644
index 000000000..b3459a9eb
--- /dev/null
+++ b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-palmetto/recipes-phosphor/ipmi/palmetto-ipmi-inventory-map/config.yaml
@@ -0,0 +1 @@
+# This file is a stub.
diff --git a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-romulus/conf/machine/romulus.conf b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-romulus/conf/machine/romulus.conf
index ae1e64495..211b8b4f0 100644
--- a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-romulus/conf/machine/romulus.conf
+++ b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-romulus/conf/machine/romulus.conf
@@ -6,8 +6,9 @@ UBOOT_MACHINE = "ast_g5_ncsi_config"
OBMC_MACHINE_FEATURES += "obmc-mrw"
PREFERRED_PROVIDER_virtual/p9-vcs-workaround = 'cpld-trigger'
+PREFERRED_PROVIDER_virtual/phosphor-ipmi-fru-config = "romulus-ipmi-inventory-map"
require conf/machine/include/ast2500.inc
require conf/machine/include/obmc-bsp-common.inc
require conf/machine/include/ibm.inc
-require conf/machine/include/p9.inc \ No newline at end of file
+require conf/machine/include/p9.inc
diff --git a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-romulus/recipes-phosphor/ipmi/romulus-ipmi-inventory-map.bb b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-romulus/recipes-phosphor/ipmi/romulus-ipmi-inventory-map.bb
new file mode 100644
index 000000000..e581d0ba7
--- /dev/null
+++ b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-romulus/recipes-phosphor/ipmi/romulus-ipmi-inventory-map.bb
@@ -0,0 +1,15 @@
+SUMMARY = "Romulus IPMI to DBus Inventory mapping."
+PR = "r1"
+
+inherit native
+inherit obmc-phosphor-license
+
+PROVIDES += "virtual/phosphor-ipmi-fru-config"
+
+do_install() {
+ DEST=${D}${datadir}/phosphor-ipmi-fru
+ install -d ${DEST}
+
+ # TODO - Run an MRW script.
+}
+
diff --git a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/conf/machine/witherspoon.conf b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/conf/machine/witherspoon.conf
index bedb6df2c..a93e11d60 100644
--- a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/conf/machine/witherspoon.conf
+++ b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/conf/machine/witherspoon.conf
@@ -6,6 +6,7 @@ UBOOT_MACHINE = "ast_g5_ncsi_config"
OBMC_MACHINE_FEATURES += "obmc-mrw"
PREFERRED_PROVIDER_virtual/p9-vcs-workaround = 'vcs-pre-post'
+PREFERRED_PROVIDER_virtual/phosphor-ipmi-fru-config = "witherspoon-ipmi-inventory-map"
require conf/machine/include/ast2500.inc
require conf/machine/include/obmc-bsp-common.inc
diff --git a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/witherspoon-ipmi-inventory-map.bb b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/witherspoon-ipmi-inventory-map.bb
new file mode 100644
index 000000000..18ce20fc3
--- /dev/null
+++ b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/witherspoon-ipmi-inventory-map.bb
@@ -0,0 +1,14 @@
+SUMMARY = "Witherspoon IPMI to DBus Inventory mapping."
+PR = "r1"
+
+inherit native
+inherit obmc-phosphor-license
+
+PROVIDES += "virtual/phosphor-ipmi-fru-config"
+
+do_install() {
+ DEST=${D}${datadir}/phosphor-ipmi-fru
+ install -d ${DEST}
+
+ # TODO - Run an MRW script.
+}
diff --git a/meta-openbmc-machines/meta-openpower/meta-rackspace/meta-barreleye/conf/machine/barreleye.conf b/meta-openbmc-machines/meta-openpower/meta-rackspace/meta-barreleye/conf/machine/barreleye.conf
index 890d9199a..819ee9d00 100644
--- a/meta-openbmc-machines/meta-openpower/meta-rackspace/meta-barreleye/conf/machine/barreleye.conf
+++ b/meta-openbmc-machines/meta-openpower/meta-rackspace/meta-barreleye/conf/machine/barreleye.conf
@@ -12,3 +12,5 @@ UBOOT_LOADADDRESS = "0x40008000"
FLASH_SIZE = "32768"
OBMC_FAN_INSTANCES = "0 1 2 3 4 5"
+
+PREFERRED_PROVIDER_virtual/phosphor-ipmi-fru-config = "barreleye-ipmi-inventory-map"
diff --git a/meta-openbmc-machines/meta-openpower/meta-rackspace/meta-barreleye/recipes-phosphor/ipmi/barreleye-ipmi-inventory-map.bb b/meta-openbmc-machines/meta-openpower/meta-rackspace/meta-barreleye/recipes-phosphor/ipmi/barreleye-ipmi-inventory-map.bb
new file mode 100644
index 000000000..7b96fc9be
--- /dev/null
+++ b/meta-openbmc-machines/meta-openpower/meta-rackspace/meta-barreleye/recipes-phosphor/ipmi/barreleye-ipmi-inventory-map.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Barreleye IPMI to DBus Inventory mapping."
+PR = "r1"
+
+inherit native
+inherit obmc-phosphor-license
+
+SRC_URI += "file://config.yaml"
+
+PROVIDES += "virtual/phosphor-ipmi-fru-config"
+
+S = "${WORKDIR}"
+
+do_install() {
+ DEST=${D}${datadir}/phosphor-ipmi-fru
+
+ install -d ${DEST}
+ install config.yaml ${DEST}
+}
+
diff --git a/meta-openbmc-machines/meta-openpower/meta-rackspace/meta-barreleye/recipes-phosphor/ipmi/barreleye-ipmi-inventory-map/config.yaml b/meta-openbmc-machines/meta-openpower/meta-rackspace/meta-barreleye/recipes-phosphor/ipmi/barreleye-ipmi-inventory-map/config.yaml
new file mode 100644
index 000000000..b3459a9eb
--- /dev/null
+++ b/meta-openbmc-machines/meta-openpower/meta-rackspace/meta-barreleye/recipes-phosphor/ipmi/barreleye-ipmi-inventory-map/config.yaml
@@ -0,0 +1 @@
+# This file is a stub.
OpenPOWER on IntegriCloud