summaryrefslogtreecommitdiffstats
path: root/meta-openbmc-machines/meta-openpower
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2017-02-09 15:08:05 -0500
committerPatrick Williams <patrick@stwcx.xyz>2017-02-09 21:09:51 +0000
commitac1ae1ff53e803bd896bec7b32084734e08720c4 (patch)
tree3205bf34b99fb1796290ca1209ecfbf1e2ccd283 /meta-openbmc-machines/meta-openpower
parent91946e7b82999679d921fb9537a01fad10f1b8ba (diff)
downloadtalos-openbmc-ac1ae1ff53e803bd896bec7b32084734e08720c4.tar.gz
talos-openbmc-ac1ae1ff53e803bd896bec7b32084734e08720c4.zip
romulus: Add a stubbed inventory map
A recipe should have been provided when obmc-mrw was removed from machine features. Change-Id: I3c211e0c76bb5e208b061365b3e7de07f37dff5e Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openbmc-machines/meta-openpower')
-rw-r--r--meta-openbmc-machines/meta-openpower/meta-ibm/meta-romulus/conf/machine/romulus.conf2
-rw-r--r--meta-openbmc-machines/meta-openpower/meta-ibm/meta-romulus/recipes-phosphor/ipmi/romulus-ipmi-inventory-map-native.bb23
-rw-r--r--meta-openbmc-machines/meta-openpower/meta-ibm/meta-romulus/recipes-phosphor/ipmi/romulus-ipmi-inventory-map/config.yaml1
3 files changed, 26 insertions, 0 deletions
diff --git a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-romulus/conf/machine/romulus.conf b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-romulus/conf/machine/romulus.conf
index 2801ee516..23e588b4d 100644
--- a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-romulus/conf/machine/romulus.conf
+++ b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-romulus/conf/machine/romulus.conf
@@ -12,3 +12,5 @@ require conf/machine/include/p9.inc
PHOSPHOR_MRW_URI = "git://github.com/open-power/romulus-xml"
PHOSPHOR_MRW_REV = "14b471fbf37f5fb60261de001df83caf5f96d81f"
+
+PREFERRED_PROVIDER_virtual/phosphor-ipmi-fru-inventory = "romulus-ipmi-inventory-map-native"
diff --git a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-romulus/recipes-phosphor/ipmi/romulus-ipmi-inventory-map-native.bb b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-romulus/recipes-phosphor/ipmi/romulus-ipmi-inventory-map-native.bb
new file mode 100644
index 000000000..c418498f5
--- /dev/null
+++ b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-romulus/recipes-phosphor/ipmi/romulus-ipmi-inventory-map-native.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Romulus IPMI to DBus Inventory mapping."
+PR = "r1"
+
+inherit native
+inherit obmc-phosphor-license
+inherit phosphor-ipmi-fru
+
+SRC_URI += "file://config.yaml"
+
+PROVIDES += "virtual/phosphor-ipmi-fru-inventory"
+
+S = "${WORKDIR}"
+
+do_install() {
+ # TODO: install this to inventory_datadir
+ # after ipmi-fru-parser untangles the host
+ # firmware config from the machine inventory.
+ DEST=${D}${config_datadir}
+
+ install -d ${DEST}
+ install config.yaml ${DEST}
+}
+
diff --git a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-romulus/recipes-phosphor/ipmi/romulus-ipmi-inventory-map/config.yaml b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-romulus/recipes-phosphor/ipmi/romulus-ipmi-inventory-map/config.yaml
new file mode 100644
index 000000000..b3459a9eb
--- /dev/null
+++ b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-romulus/recipes-phosphor/ipmi/romulus-ipmi-inventory-map/config.yaml
@@ -0,0 +1 @@
+# This file is a stub.
OpenPOWER on IntegriCloud