summaryrefslogtreecommitdiffstats
path: root/meta-openbmc-machines/meta-openpower
diff options
context:
space:
mode:
authorEdward A. James <eajames@us.ibm.com>2017-11-01 16:26:54 -0500
committerEdward A. James <eajames@us.ibm.com>2017-12-11 17:13:49 +0000
commitbb022b97b964a45a0fe34773a6a6b0d7a43bc31a (patch)
tree05bab5666dfeabb44e616aae333c432e270243d6 /meta-openbmc-machines/meta-openpower
parentaff56f45486a28856c6ac1c7a9179242bddf401f (diff)
downloadtalos-openbmc-bb022b97b964a45a0fe34773a6a6b0d7a43bc31a.tar.gz
talos-openbmc-bb022b97b964a45a0fe34773a6a6b0d7a43bc31a.zip
Add occ-disable dependency to host-crash and host-timeout
We need to unbind the occ-hmwon devices when either the host crashes or we get a watchdog timeout on the host. This is so that OCC code can start using the SBE FIFO without contention in the case of a checkstop or other host problem. Change-Id: I9ae3b1539a9eb4240cef74f2198c05b7a1b68380 Signed-off-by: Edward A. James <eajames@us.ibm.com>
Diffstat (limited to 'meta-openbmc-machines/meta-openpower')
-rw-r--r--meta-openbmc-machines/meta-openpower/common/recipes-phosphor/occ/openpower-occ-control.bb10
1 files changed, 10 insertions, 0 deletions
diff --git a/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/occ/openpower-occ-control.bb b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/occ/openpower-occ-control.bb
index 33dac2f82..9f7e52fe7 100644
--- a/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/occ/openpower-occ-control.bb
+++ b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/occ/openpower-occ-control.bb
@@ -57,4 +57,14 @@ HOST_OCC_FMT = "../${OCC_TMPL}:${HOST_TGTFMT}.requires/${OCC_INSTFMT}"
SYSTEMD_LINK_${PN} += "${@compose_list_zip(d, 'HOST_OCC_FMT', 'OCC_ENABLE', 'HOST_START', 'OBMC_HOST_INSTANCES')}"
SYSTEMD_LINK_${PN} += "${@compose_list_zip(d, 'HOST_OCC_FMT', 'OCC_DISABLE', 'HOST_STOP', 'OBMC_HOST_INSTANCES')}"
+# Set the occ disable service to be executed on host error
+HOST_ERROR_TARGETS = "crash timeout"
+
+OCC_DISABLE_TMPL = "op-occ-disable@.service"
+HOST_ERROR_TGTFMT = "obmc-host-{0}@{1}.target"
+OCC_DISABLE_INSTFMT = "op-occ-disable@{1}.service"
+HOST_ERROR_FMT = "../${OCC_DISABLE_TMPL}:${HOST_ERROR_TGTFMT}.wants/${OCC_DISABLE_INSTFMT}"
+
+SYSTEMD_LINK_${PN} += "${@compose_list(d, 'HOST_ERROR_FMT', 'HOST_ERROR_TARGETS', 'OBMC_HOST_INSTANCES')}"
+
S = "${WORKDIR}/git"
OpenPOWER on IntegriCloud