summaryrefslogtreecommitdiffstats
path: root/meta-openbmc-machines/meta-openpower/common/recipes-bsp/pflash/pflash.bb
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2016-06-08 23:06:31 -0400
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2016-06-08 23:23:02 -0400
commitf64e73c3285ac8240014afe380849c2b8a87f9fc (patch)
tree13bdceed296364764bc79edcd15a8377686c28a6 /meta-openbmc-machines/meta-openpower/common/recipes-bsp/pflash/pflash.bb
parentff436bed5775faf7fb733d12023311cff714d9d7 (diff)
downloadtalos-openbmc-f64e73c3285ac8240014afe380849c2b8a87f9fc.tar.gz
talos-openbmc-f64e73c3285ac8240014afe380849c2b8a87f9fc.zip
Bump pflash version
Move to pflash 5.2.2. Pick up a couple patches that allow building a shared library and dynamically linked pflash binary. Add pflash to SDK. Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openbmc-machines/meta-openpower/common/recipes-bsp/pflash/pflash.bb')
-rw-r--r--meta-openbmc-machines/meta-openpower/common/recipes-bsp/pflash/pflash.bb18
1 files changed, 14 insertions, 4 deletions
diff --git a/meta-openbmc-machines/meta-openpower/common/recipes-bsp/pflash/pflash.bb b/meta-openbmc-machines/meta-openpower/common/recipes-bsp/pflash/pflash.bb
index 5c0cfa4a2..496e900e7 100644
--- a/meta-openbmc-machines/meta-openpower/common/recipes-bsp/pflash/pflash.bb
+++ b/meta-openbmc-machines/meta-openpower/common/recipes-bsp/pflash/pflash.bb
@@ -4,19 +4,29 @@ HOMEPAGE = "https://github.com/open-power"
LICENSE = "Apache-2.0"
SRC_URI += "git://github.com/open-power/skiboot.git"
+
+SRC_URI += "file://0001-Make-links-target-reusable.patch"
+SRC_URI += "file://0002-external-Remove-external-shared-link-targets.patch"
+SRC_URI += "file://0003-external-Fix-pflash-install-target.patch"
+SRC_URI += "file://0004-external-Remove-m64-from-shared-CFLAGS-on-ARM.patch"
+SRC_URI += "file://0005-external-Create-shared-rules.mk.patch"
+SRC_URI += "file://0006-external-Add-dynamically-linked-pflash.patch"
+
LIC_FILES_CHKSUM = "file://${S}/LICENCE;md5=3b83ef96387f14655fc854ddc3c6bd57"
-SRCREV = "skiboot-5.2.1"
-PV = "5.2.1"
+SRCREV = "skiboot-5.2.2"
+PV = "5.2.2"
S = "${WORKDIR}/git"
EXTRA_OEMAKE = 'CROSS_COMPILE=${TARGET_PREFIX} PFLASH_VERSION=${PV} V=1'
do_compile () {
- oe_runmake -C external/pflash all
+ oe_runmake -C external/pflash all LINKAGE=dynamic
}
do_install () {
- oe_runmake -C external/pflash install DESTDIR=${D}
+ oe_runmake -C external/pflash install LINKAGE=dynamic DESTDIR=${D} PREFIX=${D}/usr
}
+
+BBCLASSEXTEND = "native nativesdk"
OpenPOWER on IntegriCloud