summaryrefslogtreecommitdiffstats
path: root/meta-openbmc-bsp
diff options
context:
space:
mode:
authorMilton D. Miller II <miltonm@us.ibm.com>2016-01-20 15:31:12 -0600
committerMilton D. Miller II <miltonm@us.ibm.com>2016-01-28 15:45:50 -0600
commit6964081624ad44c462a94f20a19c57c93cb583e8 (patch)
tree438a5d92bf9c9446f58ebae580147b3311b20cee /meta-openbmc-bsp
parentf1d00122b3714028055caa2d09888643ca743601 (diff)
downloadtalos-openbmc-6964081624ad44c462a94f20a19c57c93cb583e8.tar.gz
talos-openbmc-6964081624ad44c462a94f20a19c57c93cb583e8.zip
create u-boot-fw-utils for our u-boot version
This commit creates a class and recipie based on the upstream 2015 branch of u-boot and patches it with our fw_env.config. Having these tools for the initfs will allow us to modify the u-boot enviornment to do things like boot from network for update and set the bmc mac addresses in the environment for u-boot and use by the kernel. This commit is based on the upstream fw-utils commit. However, the initial commit was not creating target binaries. After commenting out the cross class support for creating host binaries to prepare an environment, a study of the u-boot Makefile showed that HOSTCC etc needed to be set. It is anticipated something to the commented lines will be necessary for merging upstream but this addresses our immediate use case. Signed-off-by: Milton Miller <miltonm@us.ibm.com>
Diffstat (limited to 'meta-openbmc-bsp')
-rw-r--r--meta-openbmc-bsp/meta-aspeed/meta-ast2400/recipes-bsp/u-boot/u-boot-fw-utils_2013.07%.bbappend13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta-openbmc-bsp/meta-aspeed/meta-ast2400/recipes-bsp/u-boot/u-boot-fw-utils_2013.07%.bbappend b/meta-openbmc-bsp/meta-aspeed/meta-ast2400/recipes-bsp/u-boot/u-boot-fw-utils_2013.07%.bbappend
new file mode 100644
index 000000000..40206967c
--- /dev/null
+++ b/meta-openbmc-bsp/meta-aspeed/meta-ast2400/recipes-bsp/u-boot/u-boot-fw-utils_2013.07%.bbappend
@@ -0,0 +1,13 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+SRC_URI += "file://fw_env.config"
+SRC_URI += "file://config.patch"
+
+do_install_append() {
+ if [ -e ${WORKDIR}/fw_env.config ] ; then
+ install -d ${D}${sysconfdir}
+ install -m 644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/fw_env.config
+ fi
+}
+
+BBCLASSEXTEND += "native"
OpenPOWER on IntegriCloud