summaryrefslogtreecommitdiffstats
path: root/meta-openbmc-bsp
diff options
context:
space:
mode:
authorPatrick Venture <venture@google.com>2017-06-29 12:22:12 -0700
committerPatrick Williams <patrick@stwcx.xyz>2017-07-06 21:46:08 +0000
commit51af974f81c1d8a6df250fb38c27c1a0444b2cf3 (patch)
tree4fd1fee80e821aa99948e0782b213276c6420edc /meta-openbmc-bsp
parent1008b48d57edae2cb8a71cb6842cb6868ca19b99 (diff)
downloadtalos-openbmc-51af974f81c1d8a6df250fb38c27c1a0444b2cf3.tar.gz
talos-openbmc-51af974f81c1d8a6df250fb38c27c1a0444b2cf3.zip
Add override for aspeed bsp machine.
Upstream yocto is organized such that there is only bblayer for all builds and overrides are used to customize recipes for any specific platform. It's possible for a group to use openbmc/openbmc as part of their distro and run into issues with recipes that are comingled. Change-Id: I5dc6e8c1448d95da1b5ee64b220e2955466cdf4e Signed-off-by: Patrick Venture <venture@google.com>
Diffstat (limited to 'meta-openbmc-bsp')
-rw-r--r--meta-openbmc-bsp/meta-aspeed/meta-ast2400/conf/machine/include/ast2400.inc2
-rw-r--r--meta-openbmc-bsp/meta-aspeed/meta-ast2400/recipes-bsp/u-boot/u-boot-fw-utils_%.bbappend6
-rw-r--r--meta-openbmc-bsp/meta-aspeed/meta-ast2400/recipes-bsp/u-boot/u-boot_%.bbappend4
-rw-r--r--meta-openbmc-bsp/meta-aspeed/meta-ast2400/recipes-kernel/linux/linux-obmc_%.bbappend4
-rw-r--r--meta-openbmc-bsp/meta-aspeed/meta-ast2500/conf/machine/include/ast2500.inc2
-rw-r--r--meta-openbmc-bsp/meta-aspeed/meta-ast2500/recipes-bsp/u-boot/u-boot-fw-utils_%.bbappend6
-rw-r--r--meta-openbmc-bsp/meta-aspeed/meta-ast2500/recipes-bsp/u-boot/u-boot_%.bbappend4
-rw-r--r--meta-openbmc-bsp/meta-aspeed/meta-ast2500/recipes-kernel/linux/linux-obmc_%.bbappend4
8 files changed, 18 insertions, 14 deletions
diff --git a/meta-openbmc-bsp/meta-aspeed/meta-ast2400/conf/machine/include/ast2400.inc b/meta-openbmc-bsp/meta-aspeed/meta-ast2400/conf/machine/include/ast2400.inc
index 54a2ad60e..0215a0dd1 100644
--- a/meta-openbmc-bsp/meta-aspeed/meta-ast2400/conf/machine/include/ast2400.inc
+++ b/meta-openbmc-bsp/meta-aspeed/meta-ast2400/conf/machine/include/ast2400.inc
@@ -14,4 +14,6 @@ MACHINE_EXTRA_RDEPENDS += "udev-aspeed-vuart"
SERIAL_CONSOLES = "115200;ttyS4"
+MACHINEOVERRIDES .= ":ast2400"
+
require conf/machine/include/tune-arm926ejs.inc
diff --git a/meta-openbmc-bsp/meta-aspeed/meta-ast2400/recipes-bsp/u-boot/u-boot-fw-utils_%.bbappend b/meta-openbmc-bsp/meta-aspeed/meta-ast2400/recipes-bsp/u-boot/u-boot-fw-utils_%.bbappend
index 070f389c5..375359e85 100644
--- a/meta-openbmc-bsp/meta-aspeed/meta-ast2400/recipes-bsp/u-boot/u-boot-fw-utils_%.bbappend
+++ b/meta-openbmc-bsp/meta-aspeed/meta-ast2400/recipes-bsp/u-boot/u-boot-fw-utils_%.bbappend
@@ -1,8 +1,8 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+FILESEXTRAPATHS_prepend_ast2400 := "${THISDIR}/files:"
-SRC_URI += "file://fw_env.config"
+SRC_URI_append_ast2400 = " file://fw_env.config"
-do_install_append() {
+do_install_append_ast2400() {
if [ -e ${WORKDIR}/fw_env.config ] ; then
install -d ${D}${sysconfdir}
install -m 644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/fw_env.config
diff --git a/meta-openbmc-bsp/meta-aspeed/meta-ast2400/recipes-bsp/u-boot/u-boot_%.bbappend b/meta-openbmc-bsp/meta-aspeed/meta-ast2400/recipes-bsp/u-boot/u-boot_%.bbappend
index ef6a70950..e3cc9e2a3 100644
--- a/meta-openbmc-bsp/meta-aspeed/meta-ast2400/recipes-bsp/u-boot/u-boot_%.bbappend
+++ b/meta-openbmc-bsp/meta-aspeed/meta-ast2400/recipes-bsp/u-boot/u-boot_%.bbappend
@@ -1,3 +1,3 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+FILESEXTRAPATHS_prepend_ast2400 := "${THISDIR}/files:"
-SRC_URI += "file://fw_env.config"
+SRC_URI_append_ast2400 = " file://fw_env.config"
diff --git a/meta-openbmc-bsp/meta-aspeed/meta-ast2400/recipes-kernel/linux/linux-obmc_%.bbappend b/meta-openbmc-bsp/meta-aspeed/meta-ast2400/recipes-kernel/linux/linux-obmc_%.bbappend
index 6d7ae271e..7b49ba126 100644
--- a/meta-openbmc-bsp/meta-aspeed/meta-ast2400/recipes-kernel/linux/linux-obmc_%.bbappend
+++ b/meta-openbmc-bsp/meta-aspeed/meta-ast2400/recipes-kernel/linux/linux-obmc_%.bbappend
@@ -1,2 +1,2 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-SRC_URI += "file://defconfig"
+FILESEXTRAPATHS_prepend_ast2400 := "${THISDIR}/${PN}:"
+SRC_URI_append_ast2400 = " file://defconfig"
diff --git a/meta-openbmc-bsp/meta-aspeed/meta-ast2500/conf/machine/include/ast2500.inc b/meta-openbmc-bsp/meta-aspeed/meta-ast2500/conf/machine/include/ast2500.inc
index 94e9a5934..01f299cb4 100644
--- a/meta-openbmc-bsp/meta-aspeed/meta-ast2500/conf/machine/include/ast2500.inc
+++ b/meta-openbmc-bsp/meta-aspeed/meta-ast2500/conf/machine/include/ast2500.inc
@@ -14,4 +14,6 @@ DEFAULTTUNE = "armv6-novfp"
SERIAL_CONSOLES = "115200;ttyS4"
+MACHINEOVERRIDES .= ":ast2500"
+
require conf/machine/include/arm/arch-armv6.inc
diff --git a/meta-openbmc-bsp/meta-aspeed/meta-ast2500/recipes-bsp/u-boot/u-boot-fw-utils_%.bbappend b/meta-openbmc-bsp/meta-aspeed/meta-ast2500/recipes-bsp/u-boot/u-boot-fw-utils_%.bbappend
index 070f389c5..ece33b0d4 100644
--- a/meta-openbmc-bsp/meta-aspeed/meta-ast2500/recipes-bsp/u-boot/u-boot-fw-utils_%.bbappend
+++ b/meta-openbmc-bsp/meta-aspeed/meta-ast2500/recipes-bsp/u-boot/u-boot-fw-utils_%.bbappend
@@ -1,8 +1,8 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+FILESEXTRAPATHS_prepend_ast2500 := "${THISDIR}/files:"
-SRC_URI += "file://fw_env.config"
+SRC_URI_append_ast2500 = " file://fw_env.config"
-do_install_append() {
+do_install_append_ast2500() {
if [ -e ${WORKDIR}/fw_env.config ] ; then
install -d ${D}${sysconfdir}
install -m 644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/fw_env.config
diff --git a/meta-openbmc-bsp/meta-aspeed/meta-ast2500/recipes-bsp/u-boot/u-boot_%.bbappend b/meta-openbmc-bsp/meta-aspeed/meta-ast2500/recipes-bsp/u-boot/u-boot_%.bbappend
index ef6a70950..f214b22df 100644
--- a/meta-openbmc-bsp/meta-aspeed/meta-ast2500/recipes-bsp/u-boot/u-boot_%.bbappend
+++ b/meta-openbmc-bsp/meta-aspeed/meta-ast2500/recipes-bsp/u-boot/u-boot_%.bbappend
@@ -1,3 +1,3 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+FILESEXTRAPATHS_prepend_ast2500 := "${THISDIR}/files:"
-SRC_URI += "file://fw_env.config"
+SRC_URI_append_ast2500 = " file://fw_env.config"
diff --git a/meta-openbmc-bsp/meta-aspeed/meta-ast2500/recipes-kernel/linux/linux-obmc_%.bbappend b/meta-openbmc-bsp/meta-aspeed/meta-ast2500/recipes-kernel/linux/linux-obmc_%.bbappend
index 6d7ae271e..ee9a010ea 100644
--- a/meta-openbmc-bsp/meta-aspeed/meta-ast2500/recipes-kernel/linux/linux-obmc_%.bbappend
+++ b/meta-openbmc-bsp/meta-aspeed/meta-ast2500/recipes-kernel/linux/linux-obmc_%.bbappend
@@ -1,2 +1,2 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-SRC_URI += "file://defconfig"
+FILESEXTRAPATHS_prepend_ast2500 := "${THISDIR}/${PN}:"
+SRC_URI_append_ast2500 = " file://defconfig"
OpenPOWER on IntegriCloud