summaryrefslogtreecommitdiffstats
path: root/meta-openbmc-bsp
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2018-03-23 15:28:16 -0400
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-04-18 15:01:40 +0000
commit0bbfb3e65fa60c03054259b1470350bba666ffce (patch)
treec17fea0dc35046840a80a95652d6f395091e8024 /meta-openbmc-bsp
parent18a0f79d20668e3fd9227fe2f429bc9dac8dced0 (diff)
downloadtalos-openbmc-0bbfb3e65fa60c03054259b1470350bba666ffce.tar.gz
talos-openbmc-0bbfb3e65fa60c03054259b1470350bba666ffce.zip
aspeed: move MTD partition rules
Move the MTD partition rules to their own recipe under udev rather than appending u-boot-fw-utils. Additionally the rules are an artifact of the aspeed u-boot-fw-utils configuration, so place the new recipe in the aspeed layer. Tested: Built a witherspoon image Change-Id: I1fec995dd75543b2630db29d78bfb29a1a5949d5 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openbmc-bsp')
-rw-r--r--meta-openbmc-bsp/meta-aspeed/common/recipes-bsp/u-boot/u-boot-fw-utils_2016.07.bb2
-rw-r--r--meta-openbmc-bsp/meta-aspeed/common/recipes-core/udev/udev-aspeed-mtd-partitions.bb15
-rw-r--r--meta-openbmc-bsp/meta-aspeed/common/recipes-core/udev/udev-aspeed-mtd-partitions/76-aspeed-mtd-partitions.rules1
3 files changed, 18 insertions, 0 deletions
diff --git a/meta-openbmc-bsp/meta-aspeed/common/recipes-bsp/u-boot/u-boot-fw-utils_2016.07.bb b/meta-openbmc-bsp/meta-aspeed/common/recipes-bsp/u-boot/u-boot-fw-utils_2016.07.bb
index 26314990b..9bba67e3e 100644
--- a/meta-openbmc-bsp/meta-aspeed/common/recipes-bsp/u-boot/u-boot-fw-utils_2016.07.bb
+++ b/meta-openbmc-bsp/meta-aspeed/common/recipes-bsp/u-boot/u-boot-fw-utils_2016.07.bb
@@ -34,3 +34,5 @@ SYSROOT_DIRS_append_class-cross = " ${bindir_cross}"
PACKAGE_ARCH = "${MACHINE_ARCH}"
BBCLASSEXTEND = "cross"
+
+RDEPENDS_${PN} = "udev-aspeed-mtd-partitions"
diff --git a/meta-openbmc-bsp/meta-aspeed/common/recipes-core/udev/udev-aspeed-mtd-partitions.bb b/meta-openbmc-bsp/meta-aspeed/common/recipes-core/udev/udev-aspeed-mtd-partitions.bb
new file mode 100644
index 000000000..9e85308cd
--- /dev/null
+++ b/meta-openbmc-bsp/meta-aspeed/common/recipes-core/udev/udev-aspeed-mtd-partitions.bb
@@ -0,0 +1,15 @@
+SUMMARY = "udev rules for MTD partitions"
+DESCRIPTION = "udev rules for MTD partitions"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+S = "${WORKDIR}"
+SRC_URI += "file://76-aspeed-mtd-partitions.rules"
+
+RDEPENDS_${PN} += "udev"
+
+do_install() {
+ install -d ${D}/${base_libdir}/udev/rules.d
+ install -m 0644 ${WORKDIR}/76-aspeed-mtd-partitions.rules ${D}/${base_libdir}/udev/rules.d
+}
diff --git a/meta-openbmc-bsp/meta-aspeed/common/recipes-core/udev/udev-aspeed-mtd-partitions/76-aspeed-mtd-partitions.rules b/meta-openbmc-bsp/meta-aspeed/common/recipes-core/udev/udev-aspeed-mtd-partitions/76-aspeed-mtd-partitions.rules
new file mode 100644
index 000000000..28e458645
--- /dev/null
+++ b/meta-openbmc-bsp/meta-aspeed/common/recipes-core/udev/udev-aspeed-mtd-partitions/76-aspeed-mtd-partitions.rules
@@ -0,0 +1 @@
+ENV{DEVTYPE}=="mtd", SYMLINK+="mtd/%s{name}"
OpenPOWER on IntegriCloud