summaryrefslogtreecommitdiffstats
path: root/meta-intel
diff options
context:
space:
mode:
authorMatt Spinler <spinler@us.ibm.com>2018-08-08 11:00:52 -0500
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-08-28 18:27:39 -0400
commitb7128ef47f295814ae3c8a9bb10ac1be28dd651e (patch)
tree85213de3bcb63d8eb331ad1e8b49e9dc5b76da8b /meta-intel
parent808fe4cc85098576dc65a8a465f49024700ff431 (diff)
downloadtalos-openbmc-b7128ef47f295814ae3c8a9bb10ac1be28dd651e.tar.gz
talos-openbmc-b7128ef47f295814ae3c8a9bb10ac1be28dd651e.zip
Add S2600WF GPIO JSON
These GPIOs are used by the code in the skeleton repo. (From meta-intel rev: 5ed9fa2b7afcf26db471f13845c47950939a517f) Change-Id: I40004c8b9d5258dd0af6d702b02768835820eaa1 Signed-off-by: Matt Spinler <spinler@us.ibm.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-intel')
-rw-r--r--meta-intel/meta-intel/meta-s2600wf/recipes-phosphor/skeleton/obmc-libobmc-intf.bbappend1
-rw-r--r--meta-intel/meta-intel/meta-s2600wf/recipes-phosphor/skeleton/obmc-libobmc-intf/gpio_defs.json47
2 files changed, 48 insertions, 0 deletions
diff --git a/meta-intel/meta-intel/meta-s2600wf/recipes-phosphor/skeleton/obmc-libobmc-intf.bbappend b/meta-intel/meta-intel/meta-s2600wf/recipes-phosphor/skeleton/obmc-libobmc-intf.bbappend
new file mode 100644
index 000000000..72d991c7e
--- /dev/null
+++ b/meta-intel/meta-intel/meta-s2600wf/recipes-phosphor/skeleton/obmc-libobmc-intf.bbappend
@@ -0,0 +1 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
diff --git a/meta-intel/meta-intel/meta-s2600wf/recipes-phosphor/skeleton/obmc-libobmc-intf/gpio_defs.json b/meta-intel/meta-intel/meta-s2600wf/recipes-phosphor/skeleton/obmc-libobmc-intf/gpio_defs.json
new file mode 100644
index 000000000..b02709ec2
--- /dev/null
+++ b/meta-intel/meta-intel/meta-s2600wf/recipes-phosphor/skeleton/obmc-libobmc-intf/gpio_defs.json
@@ -0,0 +1,47 @@
+{
+ "gpio_configs": {
+
+ "power_config": {
+ "power_good_in": "PGOOD",
+ "power_up_outs": [
+ {"name": "POWER_UP_PIN", "polarity": true}
+ ],
+ "reset_outs": [
+ {"name": "RESET_OUT", "polarity": false}
+ ]
+ }
+ },
+
+ "gpio_definitions": [
+ {
+ "name": "PGOOD",
+ "pin": "AB3",
+ "direction": "in"
+ },
+ {
+ "name": "POWER_BUTTON",
+ "pin": "E2",
+ "direction": "both"
+ },
+ {
+ "name": "POWER_UP_PIN",
+ "pin": "E3",
+ "direction": "out"
+ },
+ {
+ "name": "RESET_BUTTON",
+ "pin": "E0",
+ "direction": "both"
+ },
+ {
+ "name": "RESET_OUT",
+ "pin": "E1",
+ "direction": "out"
+ },
+ {
+ "name": "ID_BUTTON",
+ "pin": "S6",
+ "direction": "both"
+ }
+ ]
+}
OpenPOWER on IntegriCloud