summaryrefslogtreecommitdiffstats
path: root/meta-intel
diff options
context:
space:
mode:
authorYong Li <yong.b.li@linux.intel.com>2019-01-03 11:41:48 +0800
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-01-09 19:45:51 +0000
commit33170c397695a768aa9e00bb2928f1cf24a9bab7 (patch)
tree5e268ae2c85f95e1badd796bce7d1db90fc8dcd3 /meta-intel
parent8846a0860ee128a17a22cf158bf681672389b5b9 (diff)
downloadtalos-openbmc-33170c397695a768aa9e00bb2928f1cf24a9bab7.tar.gz
talos-openbmc-33170c397695a768aa9e00bb2928f1cf24a9bab7.zip
meta-intel: Add intel-dbus-interfaces
This recipe is used for Intel specific features and IPMI OEM commands. Tested By: bitbake intel-dbus-interfaces (From meta-intel rev: c5a33a96c6ae6eeaedc5d314c8497dc358eff589) Change-Id: I0ce1a37d271fbe43612c75308b02068426a12e0b Signed-off-by: Yong Li <yong.b.li@linux.intel.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-intel')
-rw-r--r--meta-intel/conf/layer.conf3
-rw-r--r--meta-intel/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces-mapper-config-native.bb11
-rw-r--r--meta-intel/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces_git.bb34
-rw-r--r--meta-intel/meta-common/recipes-phosphor/dbus/phosphor-mapper-config-native.bbappend1
4 files changed, 49 insertions, 0 deletions
diff --git a/meta-intel/conf/layer.conf b/meta-intel/conf/layer.conf
index edc79f88c..50fbef9aa 100644
--- a/meta-intel/conf/layer.conf
+++ b/meta-intel/conf/layer.conf
@@ -9,3 +9,6 @@ BBFILE_COLLECTIONS += "intel"
BBFILE_PATTERN_intel = ""
LAYERVERSION_intel = "1"
LAYERSERIES_COMPAT_intel = "sumo"
+
+# Provide a variable that points the base of the intel layer.
+INTELBASE = '${@os.path.normpath("${LAYERDIR}/")}'
diff --git a/meta-intel/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces-mapper-config-native.bb b/meta-intel/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces-mapper-config-native.bb
new file mode 100644
index 000000000..ce95082ce
--- /dev/null
+++ b/meta-intel/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces-mapper-config-native.bb
@@ -0,0 +1,11 @@
+SUMMARY="Add /com/intel namespace to phosphor-mapper"
+DESCRIPTION="Add the /com/intel path namespace and \
+com.intel interface prefix to the mapper watch list."
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${INTELBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
+
+inherit phosphor-mapper
+inherit native
+
+PHOSPHOR_MAPPER_SERVICE_append = " com.intel"
+PHOSPHOR_MAPPER_INTERFACE_append = " com.intel"
diff --git a/meta-intel/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces_git.bb b/meta-intel/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces_git.bb
new file mode 100644
index 000000000..14214e017
--- /dev/null
+++ b/meta-intel/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces_git.bb
@@ -0,0 +1,34 @@
+SUMMARY = "Intel DBus Interfaces"
+DESCRIPTION = "Generated bindings, using sdbus++, for the Intel YAML"
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig
+inherit pythonnative
+inherit phosphor-dbus-yaml
+
+DEPENDS += "autoconf-archive-native"
+DEPENDS += "sdbus++-native"
+
+SRC_URI = "git://github.com/openbmc/intel-dbus-interfaces"
+SRCREV = "299018f99693771c175980315a3ee54f7abd7303"
+
+DEPENDS_remove_class-native = "sdbus++-native"
+DEPENDS_remove_class-nativesdk = "sdbus++-native"
+
+PACKAGECONFIG ??= "libintel_dbus"
+PACKAGECONFIG[libintel_dbus] = " \
+ --enable-libintel_dbus, \
+ --disable-libintel_dbus, \
+ systemd sdbusplus, \
+ libsystemd sdbusplus \
+ "
+
+PACKAGECONFIG_remove_class-native = "libintel_dbus"
+PACKAGECONFIG_remove_class-nativesdk = "libintel_dbus"
+
+BBCLASSEXTEND += "native nativesdk" \ No newline at end of file
diff --git a/meta-intel/meta-common/recipes-phosphor/dbus/phosphor-mapper-config-native.bbappend b/meta-intel/meta-common/recipes-phosphor/dbus/phosphor-mapper-config-native.bbappend
new file mode 100644
index 000000000..435531878
--- /dev/null
+++ b/meta-intel/meta-common/recipes-phosphor/dbus/phosphor-mapper-config-native.bbappend
@@ -0,0 +1 @@
+PHOSPHOR_MAPPER_CONFIGS_append = " intel-dbus-interfaces-mapper-config-native"
OpenPOWER on IntegriCloud