summaryrefslogtreecommitdiffstats
path: root/meta-intel/meta-s2600wf
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2018-09-04 17:12:09 -0400
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-09-06 17:02:29 -0400
commite8f9a676bc16249d59fce062d9d0a669e5260a49 (patch)
tree0e97d48286924e2b6dff918951700a004f069ae8 /meta-intel/meta-s2600wf
parentf27bdd5a35e1af32ca3e200810222230d5fbee44 (diff)
downloadtalos-openbmc-e8f9a676bc16249d59fce062d9d0a669e5260a49.tar.gz
talos-openbmc-e8f9a676bc16249d59fce062d9d0a669e5260a49.zip
skeleton: s2600wf: fix broken gpio config path
5ed9fa2b7a erroneously introduced some new files in a meta-intel subdirectory. Move the files to the correct location. This can likely be blamed on the recent move to poky-style subtrees as 5ed9fa2b7a was originally submitted to the old, pre-subtree openbmc project repository. (From meta-intel rev: 1947fda4c79e3028e8af7a1f0bdecb7be1fb6a01) Change-Id: I9aab3002f096560e2cb376671eab02abdd2bdade Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-intel/meta-s2600wf')
-rw-r--r--meta-intel/meta-s2600wf/recipes-phosphor/skeleton/obmc-libobmc-intf.bbappend1
-rw-r--r--meta-intel/meta-s2600wf/recipes-phosphor/skeleton/obmc-libobmc-intf/gpio_defs.json47
2 files changed, 48 insertions, 0 deletions
diff --git a/meta-intel/meta-s2600wf/recipes-phosphor/skeleton/obmc-libobmc-intf.bbappend b/meta-intel/meta-s2600wf/recipes-phosphor/skeleton/obmc-libobmc-intf.bbappend
new file mode 100644
index 000000000..72d991c7e
--- /dev/null
+++ b/meta-intel/meta-s2600wf/recipes-phosphor/skeleton/obmc-libobmc-intf.bbappend
@@ -0,0 +1 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
diff --git a/meta-intel/meta-s2600wf/recipes-phosphor/skeleton/obmc-libobmc-intf/gpio_defs.json b/meta-intel/meta-s2600wf/recipes-phosphor/skeleton/obmc-libobmc-intf/gpio_defs.json
new file mode 100644
index 000000000..b02709ec2
--- /dev/null
+++ b/meta-intel/meta-s2600wf/recipes-phosphor/skeleton/obmc-libobmc-intf/gpio_defs.json
@@ -0,0 +1,47 @@
+{
+ "gpio_configs": {
+
+ "power_config": {
+ "power_good_in": "PGOOD",
+ "power_up_outs": [
+ {"name": "POWER_UP_PIN", "polarity": true}
+ ],
+ "reset_outs": [
+ {"name": "RESET_OUT", "polarity": false}
+ ]
+ }
+ },
+
+ "gpio_definitions": [
+ {
+ "name": "PGOOD",
+ "pin": "AB3",
+ "direction": "in"
+ },
+ {
+ "name": "POWER_BUTTON",
+ "pin": "E2",
+ "direction": "both"
+ },
+ {
+ "name": "POWER_UP_PIN",
+ "pin": "E3",
+ "direction": "out"
+ },
+ {
+ "name": "RESET_BUTTON",
+ "pin": "E0",
+ "direction": "both"
+ },
+ {
+ "name": "RESET_OUT",
+ "pin": "E1",
+ "direction": "out"
+ },
+ {
+ "name": "ID_BUTTON",
+ "pin": "S6",
+ "direction": "both"
+ }
+ ]
+}
OpenPOWER on IntegriCloud