summaryrefslogtreecommitdiffstats
path: root/meta-intel/meta-common/recipes-intel/ipmi
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2018-10-05 09:17:31 -0700
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-11-01 16:55:29 -0400
commit267243e1217b16094da1eac4c55de292ebad9439 (patch)
tree2ab90b7d97f753aeb49a3e3c8c98bed067596f2e /meta-intel/meta-common/recipes-intel/ipmi
parent7b32233a7868e9cf9814f203699d5afc26734221 (diff)
downloadtalos-openbmc-267243e1217b16094da1eac4c55de292ebad9439.tar.gz
talos-openbmc-267243e1217b16094da1eac4c55de292ebad9439.zip
Intel: Add recipe for Intel-specific IPMI support
This recipe builds the Intel-specifc IPMI support from the intel-ipmi-oem repository. Intel-specific IPMI support includes both OEM commands and overrides of common commands. (From meta-intel rev: 8c20b5f25d8f9fb5154c0e6c954beda807a67702) Change-Id: If66e544d3b8e7c9cc498454e17d490d482fcdda7 Signed-off-by: Jason M. Bills <jason.m.bills@linux.intel.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-intel/meta-common/recipes-intel/ipmi')
-rwxr-xr-xmeta-intel/meta-common/recipes-intel/ipmi/intel-ipmi-oem_git.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-intel/meta-common/recipes-intel/ipmi/intel-ipmi-oem_git.bb b/meta-intel/meta-common/recipes-intel/ipmi/intel-ipmi-oem_git.bb
new file mode 100755
index 000000000..5c17dfc55
--- /dev/null
+++ b/meta-intel/meta-common/recipes-intel/ipmi/intel-ipmi-oem_git.bb
@@ -0,0 +1,29 @@
+SUMMARY = "Intel OEM IPMI commands"
+DESCRIPTION = "Intel OEM IPMI commands"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=a6a4edad4aed50f39a66d098d74b265b"
+
+SRC_URI = "git://github.com/openbmc/intel-ipmi-oem"
+SRCREV = "6479604111b8198592c1054a3bad751f3b80a689"
+
+S = "${WORKDIR}/git"
+PV = "0.1+git${SRCPV}"
+
+DEPENDS = "boost phosphor-ipmi-host systemd microsoft-gsl"
+
+inherit cmake obmc-phosphor-ipmiprovider-symlink
+
+EXTRA_OECMAKE="-DENABLE_TEST=0 -DYOCTO=1"
+
+LIBRARY_NAMES = "libsensorcommands.so"
+LIBRARY_NAMES += "libzstoragecommands.so"
+LIBRARY_NAMES += "liboemcmds.so"
+
+HOSTIPMI_PROVIDER_LIBRARY += "${LIBRARY_NAMES}"
+NETIPMI_PROVIDER_LIBRARY += "${LIBRARY_NAMES}"
+
+FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
+FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
+FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
+FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV}"
OpenPOWER on IntegriCloud