summaryrefslogtreecommitdiffstats
path: root/meta-ingrasys
diff options
context:
space:
mode:
authorMatt Spinler <spinler@us.ibm.com>2018-08-08 10:57:02 -0500
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-08-28 18:26:30 -0400
commit2d8fc1140654b7d97a4e6806ab1617a34c2a7f70 (patch)
tree6fcd6839c59242732fefcbd53fb3aff5c274df39 /meta-ingrasys
parent7d060d077e3ca934a4e23001f30bf9c69359f468 (diff)
downloadtalos-openbmc-2d8fc1140654b7d97a4e6806ab1617a34c2a7f70.tar.gz
talos-openbmc-2d8fc1140654b7d97a4e6806ab1617a34c2a7f70.zip
Add Zaius GPIO JSON
These GPIOs are used by the code in the skeleton repo. (From meta-ingrasys rev: 5d62d701c830a68eb2ca20246535787ea4456355) Change-Id: I999f36730a33dd61051a9ce691fdfb8fd05a9ec5 Signed-off-by: Matt Spinler <spinler@us.ibm.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-ingrasys')
-rw-r--r--meta-ingrasys/meta-ingrasys/meta-zaius/recipes-phosphor/skeleton/obmc-libobmc-intf.bbappend1
-rw-r--r--meta-ingrasys/meta-ingrasys/meta-zaius/recipes-phosphor/skeleton/obmc-libobmc-intf/gpio_defs.json78
2 files changed, 79 insertions, 0 deletions
diff --git a/meta-ingrasys/meta-ingrasys/meta-zaius/recipes-phosphor/skeleton/obmc-libobmc-intf.bbappend b/meta-ingrasys/meta-ingrasys/meta-zaius/recipes-phosphor/skeleton/obmc-libobmc-intf.bbappend
new file mode 100644
index 000000000..72d991c7e
--- /dev/null
+++ b/meta-ingrasys/meta-ingrasys/meta-zaius/recipes-phosphor/skeleton/obmc-libobmc-intf.bbappend
@@ -0,0 +1 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
diff --git a/meta-ingrasys/meta-ingrasys/meta-zaius/recipes-phosphor/skeleton/obmc-libobmc-intf/gpio_defs.json b/meta-ingrasys/meta-ingrasys/meta-zaius/recipes-phosphor/skeleton/obmc-libobmc-intf/gpio_defs.json
new file mode 100644
index 000000000..305f41c46
--- /dev/null
+++ b/meta-ingrasys/meta-ingrasys/meta-zaius/recipes-phosphor/skeleton/obmc-libobmc-intf/gpio_defs.json
@@ -0,0 +1,78 @@
+{
+ "gpio_configs": {
+
+ "power_config": {
+ "power_good_in": "SYS_PWROK_BUFF",
+ "latch_out": "BMC_UCD_LATCH_LE",
+ "power_up_outs": [
+ { "name": "SOFTWARE_PGOOD", "polarity": true},
+ { "name": "BMC_POWER_UP", "polarity": true}
+ ],
+ "reset_outs": [
+ ]
+ }
+ },
+
+ "gpio_definitions": [
+ {
+ "name": "SOFTWARE_PGOOD",
+ "pin": "R1",
+ "direction": "out"
+ },
+ {
+ "name": "BMC_POWER_UP",
+ "pin": "D1",
+ "direction": "out"
+ },
+ {
+ "name": "SYS_PWROK_BUFF",
+ "pin": "D2",
+ "direction": "in"
+ },
+ {
+ "name": "PHY_RST_N",
+ "pin": "D3",
+ "direction": "out"
+ },
+ {
+ "name": "HDD_PWR_EN",
+ "pin": "D4",
+ "direction": "out"
+ },
+ {
+ "name": "CP0_DEVICES_RESET_N",
+ "pin": "A1",
+ "direction": "out"
+ },
+ {
+ "name": "BMC_CP0_PERST_ENABLE",
+ "pin": "A3",
+ "direction": "out"
+ },
+ {
+ "name": "BMC_UCD_LATCH_LE",
+ "pin": "B4",
+ "direction": "out"
+ },
+ {
+ "name": "POWER_BUTTON",
+ "pin": "I3",
+ "direction": "both"
+ },
+ {
+ "name": "RESET_BUTTON",
+ "pin": "AA0",
+ "direction": "both"
+ },
+ {
+ "name": "PE_MEZZB_PRSNT_N",
+ "pin": "P7",
+ "direction": "in"
+ },
+ {
+ "name": "CHECKSTOP",
+ "pin": "F7",
+ "direction": "falling"
+ }
+ ]
+}
OpenPOWER on IntegriCloud