summaryrefslogtreecommitdiffstats
path: root/meta-ibm
diff options
context:
space:
mode:
authorBrandon Wyman <bjwyman@gmail.com>2019-03-13 13:27:13 -0500
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-04-16 12:58:05 -0400
commitf0a24b82d0482e2231da180a6059d5cd99deae96 (patch)
tree1c0652cf03dcbb7ac02e6d56c45c8d5939312d00 /meta-ibm
parentc03a3d5e207d52ad35b852a19d66cafd0945b2f7 (diff)
downloadtalos-openbmc-f0a24b82d0482e2231da180a6059d5cd99deae96.tar.gz
talos-openbmc-f0a24b82d0482e2231da180a6059d5cd99deae96.zip
Remove witherspoon prefix from pfault-analysis
Remove the witherspoon prefix from the witherspoon-pfault-analysis based recipes for applications and service files to avoid confusion when these are reused by Swift. Point to latest commit of witherspoon-pfault-analysis. Requires: I4c7275c3b14b3b3724abb98b8d43610df4f9c2a3 https://gerrit.openbmc-project.xyz/c/openbmc/witherspoon-pfault-analysis/+/19399 (From meta-ibm rev: fe3a464e30811d89cad55aab795523fd6152b5a8) Change-Id: Ic73d31809794b5033126549044d7e4ff00653118 Signed-off-by: Brandon Wyman <bjwyman@gmail.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-ibm')
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis.inc2
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis/power-supply-monitor@.service (renamed from meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis/witherspoon-power-supply-monitor@.service)6
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis/pseq-monitor-pgood.service (renamed from meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis/witherspoon-pseq-monitor-pgood.service)6
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis/pseq-monitor.service10
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis/witherspoon-pseq-monitor.service10
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis_git.bb10
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-power-supply-sync.bb4
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-power-supply-sync/power-supply-sync.service (renamed from meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-power-supply-sync/witherspoon-power-supply-sync.service)4
8 files changed, 26 insertions, 26 deletions
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis.inc b/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis.inc
index be1ebd4ba..264854358 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis.inc
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis.inc
@@ -2,4 +2,4 @@ HOMEPAGE = "https://github.com/openbmc/witherspoon-pfault-analysis"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
SRC_URI += "git://github.com/openbmc/witherspoon-pfault-analysis"
-SRCREV = "57bee329bbf1b67dd159f103b634be2fede08822"
+SRCREV = "05be4a92c287d957fb7bd3f67b1b722276c12b16"
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis/witherspoon-power-supply-monitor@.service b/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis/power-supply-monitor@.service
index 56e2d218a..bf027582d 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis/witherspoon-power-supply-monitor@.service
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis/power-supply-monitor@.service
@@ -1,5 +1,5 @@
[Unit]
-Description=Witherspoon Power Supply %I Monitor
+Description=Power Supply %I Monitor
Wants=mapper-wait@-xyz-openbmc_project-inventory-system-chassis-motherboard-powersupply%i.service
After=mapper-wait@-xyz-openbmc_project-inventory-system-chassis-motherboard-powersupply%i.service
Wants=mapper-wait@-org-openbmc-control-power0.service
@@ -8,8 +8,8 @@ ConditionPathExists={envfiledir}/obmc/power-supply-monitor/power-supply-monitor-
[Service]
EnvironmentFile={envfiledir}/obmc/power-supply-monitor/power-supply-monitor-%i.conf
-ExecStart=/usr/bin/env witherspoon-psu-monitor --path=${{DEVPATH}} --instance=${{INSTANCE}} --inventory=${{INVENTORY}} --num-history-records=${{NUM_HISTORY_RECORDS}} --sync-gpio-path=${{SYNC_GPIO_PATH}} --sync-gpio-num=${{SYNC_GPIO_NUM}}
-SyslogIdentifier=witherspoon-psu-monitor
+ExecStart=/usr/bin/env psu-monitor --path=${{DEVPATH}} --instance=${{INSTANCE}} --inventory=${{INVENTORY}} --num-history-records=${{NUM_HISTORY_RECORDS}} --sync-gpio-path=${{SYNC_GPIO_PATH}} --sync-gpio-num=${{SYNC_GPIO_NUM}}
+SyslogIdentifier=psu-monitor
[Install]
RequiredBy=multi-user.target
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis/witherspoon-pseq-monitor-pgood.service b/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis/pseq-monitor-pgood.service
index ff6bcd181..458c5e6d7 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis/witherspoon-pseq-monitor-pgood.service
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis/pseq-monitor-pgood.service
@@ -1,5 +1,5 @@
[Unit]
-Description=Witherspoon Power Sequencer Power-on Monitor
+Description=Power Sequencer Power-on Monitor
Wants=op-power-start@0.service
After=op-power-start@0.service
Wants=power-workarounds@0.service
@@ -9,5 +9,5 @@ ConditionPathExists=!/run/openbmc/chassis@0-on
[Service]
Type=oneshot
-ExecStart=/usr/bin/env witherspoon-pseq-monitor -a pgood-monitor -i 5000
-SyslogIdentifier=witherspoon-pseq-monitor
+ExecStart=/usr/bin/env pseq-monitor -a pgood-monitor -i 5000
+SyslogIdentifier=pseq-monitor
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis/pseq-monitor.service b/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis/pseq-monitor.service
new file mode 100644
index 000000000..8ce3b370d
--- /dev/null
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis/pseq-monitor.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=Power Sequencer Runtime Monitor
+Wants=obmc-host-start-pre@0.target
+Before=obmc-host-start-pre@0.target
+After=obmc-power-on@0.target
+Conflicts=obmc-chassis-poweroff@0.target
+
+[Service]
+ExecStart=/usr/bin/env pseq-monitor -a runtime-monitor -i 500
+SyslogIdentifier=pseq-monitor
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis/witherspoon-pseq-monitor.service b/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis/witherspoon-pseq-monitor.service
deleted file mode 100644
index 6e76c8f48..000000000
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis/witherspoon-pseq-monitor.service
+++ /dev/null
@@ -1,10 +0,0 @@
-[Unit]
-Description=Witherspoon Power Sequencer Runtime Monitor
-Wants=obmc-host-start-pre@0.target
-Before=obmc-host-start-pre@0.target
-After=obmc-power-on@0.target
-Conflicts=obmc-chassis-poweroff@0.target
-
-[Service]
-ExecStart=/usr/bin/env witherspoon-pseq-monitor -a runtime-monitor -i 500
-SyslogIdentifier=witherspoon-pseq-monitor
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis_git.bb b/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis_git.bb
index c50765795..51086c675 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis_git.bb
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis_git.bb
@@ -21,21 +21,21 @@ DEPENDS += " \
"
CHASSIS_ON_TGT = "obmc-chassis-poweron@0.target"
-SEQ_MONITOR_SVC = "witherspoon-pseq-monitor.service"
+SEQ_MONITOR_SVC = "pseq-monitor.service"
SEQ_MONITOR_FMT = "../${SEQ_MONITOR_SVC}:${CHASSIS_ON_TGT}.wants/${SEQ_MONITOR_SVC}"
-SEQ_PGOOD_SVC = "witherspoon-pseq-monitor-pgood.service"
+SEQ_PGOOD_SVC = "pseq-monitor-pgood.service"
SEQ_PGOOD_FMT = "../${SEQ_PGOOD_SVC}:${CHASSIS_ON_TGT}.wants/${SEQ_PGOOD_SVC}"
SYSTEMD_SERVICE_${PN} += "${SEQ_MONITOR_SVC} ${SEQ_PGOOD_SVC}"
SYSTEMD_LINK_${PN} += "${SEQ_MONITOR_FMT} ${SEQ_PGOOD_FMT}"
-PSU_MONITOR_TMPL = "witherspoon-power-supply-monitor@.service"
-PSU_MONITOR_INSTFMT = "witherspoon-power-supply-monitor@{0}.service"
+PSU_MONITOR_TMPL = "power-supply-monitor@.service"
+PSU_MONITOR_INSTFMT = "power-supply-monitor@{0}.service"
PSU_MONITOR_TGT = "multi-user.target"
PSU_MONITOR_FMT = "../${PSU_MONITOR_TMPL}:${PSU_MONITOR_TGT}.requires/${PSU_MONITOR_INSTFMT}"
-FILES_witherspoon-psu-monitor = "${sbindir}/witherspoon-psu-monitor"
+FILES_psu-monitor = "${bindir}/psu-monitor"
SYSTEMD_SERVICE_${PN} += "${PSU_MONITOR_TMPL}"
SYSTEMD_LINK_${PN} += "${@compose_list(d, 'PSU_MONITOR_FMT', 'OBMC_POWER_SUPPLY_INSTANCES')}"
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-power-supply-sync.bb b/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-power-supply-sync.bb
index ea7804bcd..a2d7e8919 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-power-supply-sync.bb
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-power-supply-sync.bb
@@ -1,4 +1,4 @@
-SUMMARY = "Witherspoon Power Supply Sync"
+SUMMARY = "Power Supply Sync"
DESCRIPTION = "Synchronizes the power supplies' INPUT_HISTORY data"
PR = "r1"
LICENSE = "Apache-2.0"
@@ -8,7 +8,7 @@ inherit obmc-phosphor-systemd
RDEPENDS_${PN} += "virtual/obmc-gpio-monitor"
-SYNC_SERVICE = "witherspoon-power-supply-sync.service"
+SYNC_SERVICE = "power-supply-sync.service"
TGTFMT = "obmc-chassis-poweron@0.target"
SYNC_FMT = "../${SYNC_SERVICE}:${TGTFMT}.wants/${SYNC_SERVICE}"
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-power-supply-sync/witherspoon-power-supply-sync.service b/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-power-supply-sync/power-supply-sync.service
index 005a0141d..9e342367b 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-power-supply-sync/witherspoon-power-supply-sync.service
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-power-supply-sync/power-supply-sync.service
@@ -1,5 +1,5 @@
[Unit]
-Description=Witherspoon Power Supply Input History SYNC
+Description=Power Supply Input History SYNC
Wants=obmc-power-start-pre@0.target
After=obmc-power-start-pre@0.target
Wants=obmc-chassis-poweron@0.target
@@ -8,7 +8,7 @@ ConditionPathExists=!/run/openbmc/chassis@0-on
[Service]
ExecStart=/usr/bin/env phosphor-gpio-util --gpio=105 --path=/dev/gpiochip0 --delay=5 --action=low_high
-SyslogIdentifier=witherspoon-power-supply-sync
+SyslogIdentifier=power-supply-sync
[Install]
RequiredBy=obmc-chassis-poweron@0.target
OpenPOWER on IntegriCloud