summaryrefslogtreecommitdiffstats
path: root/meta-ibm
diff options
context:
space:
mode:
authorMatt Spinler <spinler@us.ibm.com>2018-08-08 10:58:52 -0500
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-08-28 14:57:21 -0400
commit7d060d077e3ca934a4e23001f30bf9c69359f468 (patch)
tree555dba2b8b2909cc23679e3332def172a27d8d9a /meta-ibm
parent2a80da2262bf13aa1ddb589cf3f2b672d26b0975 (diff)
downloadtalos-openbmc-7d060d077e3ca934a4e23001f30bf9c69359f468.tar.gz
talos-openbmc-7d060d077e3ca934a4e23001f30bf9c69359f468.zip
Add Palmetto GPIO JSON
These GPIOs are used by the code in the skeleton repo. (From meta-ibm rev: 2ba966c18046651d2115d732cbb0ed8b231bafad) Change-Id: I58a5087252b5dc6a98174837305485925c07c712 Signed-off-by: Matt Spinler <spinler@us.ibm.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-ibm')
-rw-r--r--meta-ibm/meta-palmetto/recipes-phosphor/skeleton/obmc-libobmc-intf.bbappend1
-rw-r--r--meta-ibm/meta-palmetto/recipes-phosphor/skeleton/obmc-libobmc-intf/gpio_defs.json60
2 files changed, 61 insertions, 0 deletions
diff --git a/meta-ibm/meta-palmetto/recipes-phosphor/skeleton/obmc-libobmc-intf.bbappend b/meta-ibm/meta-palmetto/recipes-phosphor/skeleton/obmc-libobmc-intf.bbappend
new file mode 100644
index 000000000..72d991c7e
--- /dev/null
+++ b/meta-ibm/meta-palmetto/recipes-phosphor/skeleton/obmc-libobmc-intf.bbappend
@@ -0,0 +1 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
diff --git a/meta-ibm/meta-palmetto/recipes-phosphor/skeleton/obmc-libobmc-intf/gpio_defs.json b/meta-ibm/meta-palmetto/recipes-phosphor/skeleton/obmc-libobmc-intf/gpio_defs.json
new file mode 100644
index 000000000..5ca21e3e2
--- /dev/null
+++ b/meta-ibm/meta-palmetto/recipes-phosphor/skeleton/obmc-libobmc-intf/gpio_defs.json
@@ -0,0 +1,60 @@
+{
+ "gpio_configs": {
+
+ "power_config": {
+ "power_good_in": "PGOOD",
+ "power_up_outs": [
+ {"name": "POWER_PIN", "polarity": false}
+ ],
+ "reset_outs": [
+ {"name": "USB_RESET", "polarity": false}
+ ],
+ "pci_reset_outs": [
+ {"name": "PCIE_RESET", "polarity": false, "hold": false}
+ ]
+ }
+ },
+
+ "gpio_definitions": [
+ {
+ "name": "POWER_PIN",
+ "pin": "E1",
+ "direction": "out"
+ },
+ {
+ "name": "PGOOD",
+ "pin": "C7",
+ "direction": "in"
+ },
+ {
+ "name": "BMC_THROTTLE",
+ "pin": "J3",
+ "direction": "out"
+ },
+ {
+ "name": "IDBTN",
+ "pin": "Q7",
+ "direction": "out"
+ },
+ {
+ "name": "POWER_BUTTON",
+ "pin": "E0",
+ "direction": "both"
+ },
+ {
+ "name": "PCIE_RESET",
+ "pin": "B5",
+ "direction": "out"
+ },
+ {
+ "name": "USB_RESET",
+ "pin": "B6",
+ "direction": "out"
+ },
+ {
+ "name": "CHECKSTOP",
+ "pin": "P5",
+ "direction": "falling"
+ }
+ ]
+}
OpenPOWER on IntegriCloud