summaryrefslogtreecommitdiffstats
path: root/meta-ibm
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2018-11-07 13:04:06 -0800
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-11-08 07:57:26 -0500
commit6738f35e8e3acfad6f04860fcbc299a2691f281a (patch)
treed8258b93687b98d2cbf2e556f7a77429895a538f /meta-ibm
parent2879d326eb675a9e49447739918589c8814f015d (diff)
downloadtalos-openbmc-6738f35e8e3acfad6f04860fcbc299a2691f281a.tar.gz
talos-openbmc-6738f35e8e3acfad6f04860fcbc299a2691f281a.zip
meta-ibm: master refresh baedc91099..a00d9b8a84
Update meta-ibm to master HEAD. Patrick Venture (21): meta-ibm: add IBMBASE meta-ibm: romulus: chassis: avsbus-control: set LICENSE field meta-ibm: romulus: chassis: vrm-control: set LICENSE field meta-ibm: romulus: gpio: id-button: set LICENSE field meta-ibm: romulus: ipmi-fru-read-inventory-native: set LICENSE field meta-ibm: romulus: ipmi-inventory-map-native: set LICENSE field meta-ibm: romulus: ipmi-inventory-sel-native: set LICENSE field meta-ibm: romulus: led-manager-config-native: set LICENSE field meta-ibm: romulus; phosphor-logging-callouts-native: set LICENSE field meta-ibm: witherspoon: chassis: avsbus-control: set LICENSE field meta-ibm: witherspoon: chassis: vrm-control: set LICENSE field meta-ibm: witherspoon: events-policy-native: set LICENSE field meta-ibm: witherspoon: fan-policy-native: set LICENSE field meta-ibm: witherspoon: fan-watchdog: set LICENSE field meta-ibm: witherspoon: thermal-policy-native: set LICENSE field meta-ibm: witherspoon: inventory-cleanup-native: set LICENSE field meta-ibm: witherspoon: power-supply-policy-native: set LICENSE field meta-ibm: witherspoon: power-supply-sync: set LICENSE field meta-ibm: palmetto: ipmi-inventory-map-native: set LICENSE field meta-ibm: palmetto: led-manager-config-native: set LICENSE field meta-ibm: dbus-interfaces-mapper-config-native: set LICENSE field Change-Id: Ic74e30b1cdd013c7d293dffc9423035632f92e43 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-ibm')
-rw-r--r--meta-ibm/conf/layer.conf3
-rw-r--r--meta-ibm/meta-palmetto/recipes-phosphor/ipmi/palmetto-ipmi-inventory-map-native.bb3
-rw-r--r--meta-ibm/meta-palmetto/recipes-phosphor/leds/palmetto-led-manager-config-native.bb3
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/chassis/avsbus-control.bb3
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/chassis/vrm-control.bb3
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/gpio/id-button.bb3
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/ipmi/romulus-ipmi-fru-read-inventory-native.bb3
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/ipmi/romulus-ipmi-inventory-map-native.bb3
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/ipmi/romulus-ipmi-inventory-sel-native.bb3
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/leds/romulus-led-manager-config-native.bb3
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/logging/romulus-phosphor-logging-callouts-native.bb3
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/chassis/avsbus-control.bb3
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/chassis/vrm-control.bb3
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/events/witherspoon-events-policy-native.bb3
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-fan-policy-native.bb3
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-fan-watchdog.bb3
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-thermal-policy-native.bb3
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/inventory/inventory-cleanup-native.bb3
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-power-supply-policy-native.bb3
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-power-supply-sync.bb3
-rw-r--r--meta-ibm/recipes-phosphor/dbus/ibm-dbus-interfaces-mapper-config-native.bb3
21 files changed, 43 insertions, 20 deletions
diff --git a/meta-ibm/conf/layer.conf b/meta-ibm/conf/layer.conf
index 72351f158..434f61695 100644
--- a/meta-ibm/conf/layer.conf
+++ b/meta-ibm/conf/layer.conf
@@ -8,3 +8,6 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
BBFILE_COLLECTIONS += "ibm-layer"
BBFILE_PATTERN_ibm-layer = ""
LAYERSERIES_COMPAT_ibm-layer = "sumo"
+
+# Provide a variable that points the base of the ibm layer.
+IBMBASE = '${@os.path.normpath("${LAYERDIR}/")}'
diff --git a/meta-ibm/meta-palmetto/recipes-phosphor/ipmi/palmetto-ipmi-inventory-map-native.bb b/meta-ibm/meta-palmetto/recipes-phosphor/ipmi/palmetto-ipmi-inventory-map-native.bb
index 2b5348a9f..8e328d846 100644
--- a/meta-ibm/meta-palmetto/recipes-phosphor/ipmi/palmetto-ipmi-inventory-map-native.bb
+++ b/meta-ibm/meta-palmetto/recipes-phosphor/ipmi/palmetto-ipmi-inventory-map-native.bb
@@ -1,8 +1,9 @@
SUMMARY = "Palmetto IPMI to DBus Inventory mapping."
PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
inherit native
-inherit obmc-phosphor-license
inherit phosphor-ipmi-fru
SRC_URI += "file://config.yaml"
diff --git a/meta-ibm/meta-palmetto/recipes-phosphor/leds/palmetto-led-manager-config-native.bb b/meta-ibm/meta-palmetto/recipes-phosphor/leds/palmetto-led-manager-config-native.bb
index d633fd980..a7e8c6b74 100644
--- a/meta-ibm/meta-palmetto/recipes-phosphor/leds/palmetto-led-manager-config-native.bb
+++ b/meta-ibm/meta-palmetto/recipes-phosphor/leds/palmetto-led-manager-config-native.bb
@@ -1,8 +1,9 @@
SUMMARY = "Phosphor LED Group Management for Palmetto"
PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
inherit native
-inherit obmc-phosphor-license
PROVIDES += "virtual/phosphor-led-manager-config-native"
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/chassis/avsbus-control.bb b/meta-ibm/meta-romulus/recipes-phosphor/chassis/avsbus-control.bb
index 252d2cbfc..ca45a1eb3 100644
--- a/meta-ibm/meta-romulus/recipes-phosphor/chassis/avsbus-control.bb
+++ b/meta-ibm/meta-romulus/recipes-phosphor/chassis/avsbus-control.bb
@@ -1,8 +1,9 @@
SUMMARY = "Romulus AVSBus control"
PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
inherit obmc-phosphor-systemd
-inherit obmc-phosphor-license
RDEPENDS_${PN} += "i2c-tools bash"
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/chassis/vrm-control.bb b/meta-ibm/meta-romulus/recipes-phosphor/chassis/vrm-control.bb
index e23bdd077..ba38b8769 100644
--- a/meta-ibm/meta-romulus/recipes-phosphor/chassis/vrm-control.bb
+++ b/meta-ibm/meta-romulus/recipes-phosphor/chassis/vrm-control.bb
@@ -1,9 +1,10 @@
SUMMARY = "Romulus VRM Overrides"
DESCRIPTION = "Sets Rolumus VRMs to custom voltages"
PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
inherit obmc-phosphor-systemd
-inherit obmc-phosphor-license
RDEPENDS_${PN} += "i2c-tools bash"
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/gpio/id-button.bb b/meta-ibm/meta-romulus/recipes-phosphor/gpio/id-button.bb
index 7267ee3d5..90513b4d1 100644
--- a/meta-ibm/meta-romulus/recipes-phosphor/gpio/id-button.bb
+++ b/meta-ibm/meta-romulus/recipes-phosphor/gpio/id-button.bb
@@ -1,8 +1,9 @@
SUMMARY = "Romulus ID Button pressed application"
PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
inherit obmc-phosphor-systemd
-inherit obmc-phosphor-license
DEPENDS += "virtual/obmc-gpio-monitor"
RDEPENDS_${PN} += "virtual/obmc-gpio-monitor"
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/ipmi/romulus-ipmi-fru-read-inventory-native.bb b/meta-ibm/meta-romulus/recipes-phosphor/ipmi/romulus-ipmi-fru-read-inventory-native.bb
index 5551200e1..6f416c1a7 100644
--- a/meta-ibm/meta-romulus/recipes-phosphor/ipmi/romulus-ipmi-fru-read-inventory-native.bb
+++ b/meta-ibm/meta-romulus/recipes-phosphor/ipmi/romulus-ipmi-fru-read-inventory-native.bb
@@ -1,8 +1,9 @@
SUMMARY = "Romulus inventory map for phosphor-ipmi-host"
PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
inherit native
-inherit obmc-phosphor-license
inherit phosphor-ipmi-host
SRC_URI += "file://config.yaml"
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/ipmi/romulus-ipmi-inventory-map-native.bb b/meta-ibm/meta-romulus/recipes-phosphor/ipmi/romulus-ipmi-inventory-map-native.bb
index c418498f5..c0620ff5d 100644
--- a/meta-ibm/meta-romulus/recipes-phosphor/ipmi/romulus-ipmi-inventory-map-native.bb
+++ b/meta-ibm/meta-romulus/recipes-phosphor/ipmi/romulus-ipmi-inventory-map-native.bb
@@ -1,8 +1,9 @@
SUMMARY = "Romulus IPMI to DBus Inventory mapping."
PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
inherit native
-inherit obmc-phosphor-license
inherit phosphor-ipmi-fru
SRC_URI += "file://config.yaml"
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/ipmi/romulus-ipmi-inventory-sel-native.bb b/meta-ibm/meta-romulus/recipes-phosphor/ipmi/romulus-ipmi-inventory-sel-native.bb
index 93907c858..60904656f 100644
--- a/meta-ibm/meta-romulus/recipes-phosphor/ipmi/romulus-ipmi-inventory-sel-native.bb
+++ b/meta-ibm/meta-romulus/recipes-phosphor/ipmi/romulus-ipmi-inventory-sel-native.bb
@@ -1,9 +1,10 @@
SUMMARY = "Inventory to Sensor config for Romulus"
PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
inherit native
inherit phosphor-ipmi-host
-inherit obmc-phosphor-license
PROVIDES += "virtual/phosphor-ipmi-inventory-sel"
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/leds/romulus-led-manager-config-native.bb b/meta-ibm/meta-romulus/recipes-phosphor/leds/romulus-led-manager-config-native.bb
index 3c7adaaac..9b511e015 100644
--- a/meta-ibm/meta-romulus/recipes-phosphor/leds/romulus-led-manager-config-native.bb
+++ b/meta-ibm/meta-romulus/recipes-phosphor/leds/romulus-led-manager-config-native.bb
@@ -1,8 +1,9 @@
SUMMARY = "Phosphor LED Group Management for Romulus"
PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
inherit native
-inherit obmc-phosphor-license
PROVIDES += "virtual/phosphor-led-manager-config-native"
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/logging/romulus-phosphor-logging-callouts-native.bb b/meta-ibm/meta-romulus/recipes-phosphor/logging/romulus-phosphor-logging-callouts-native.bb
index 375213957..a6fd5b1f9 100644
--- a/meta-ibm/meta-romulus/recipes-phosphor/logging/romulus-phosphor-logging-callouts-native.bb
+++ b/meta-ibm/meta-romulus/recipes-phosphor/logging/romulus-phosphor-logging-callouts-native.bb
@@ -1,8 +1,9 @@
SUMMARY = "Romulus inventory map for phosphor-ipmi-host"
PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
inherit native
-inherit obmc-phosphor-license
inherit phosphor-logging
SRC_URI += "file://callouts.yaml"
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/chassis/avsbus-control.bb b/meta-ibm/meta-witherspoon/recipes-phosphor/chassis/avsbus-control.bb
index a09cdc750..5abe1be1f 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/chassis/avsbus-control.bb
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/chassis/avsbus-control.bb
@@ -1,8 +1,9 @@
SUMMARY = "Witherspoon AVSBus control"
PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
inherit obmc-phosphor-systemd
-inherit obmc-phosphor-license
RDEPENDS_${PN} += "i2c-tools"
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/chassis/vrm-control.bb b/meta-ibm/meta-witherspoon/recipes-phosphor/chassis/vrm-control.bb
index d05e67fb9..36416e949 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/chassis/vrm-control.bb
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/chassis/vrm-control.bb
@@ -1,9 +1,10 @@
SUMMARY = "Witherspoon VRM Overrides"
DESCRIPTION = "Sets Witherspoon VRMs to custom voltages"
PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
inherit obmc-phosphor-systemd
-inherit obmc-phosphor-license
RDEPENDS_${PN} += "i2c-tools bash"
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/events/witherspoon-events-policy-native.bb b/meta-ibm/meta-witherspoon/recipes-phosphor/events/witherspoon-events-policy-native.bb
index c478e12b7..e855754c5 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/events/witherspoon-events-policy-native.bb
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/events/witherspoon-events-policy-native.bb
@@ -1,8 +1,9 @@
SUMMARY = "Event policy for Witherspoon"
PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
inherit native
-inherit obmc-phosphor-license
inherit phosphor-dbus-monitor
SRC_URI += "file://config.yaml"
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-fan-policy-native.bb b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-fan-policy-native.bb
index b7da45c01..070fceeec 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-fan-policy-native.bb
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-fan-policy-native.bb
@@ -1,8 +1,9 @@
SUMMARY = "Fan policy for Witherspoon"
PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
inherit native
-inherit obmc-phosphor-license
inherit phosphor-dbus-monitor
SRC_URI += "file://air-cooled.yaml"
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-fan-watchdog.bb b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-fan-watchdog.bb
index c09b9df24..357de9516 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-fan-watchdog.bb
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-fan-watchdog.bb
@@ -1,7 +1,8 @@
SUMMARY = "Witherspoon fan watchdog services"
PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
-inherit obmc-phosphor-license
inherit obmc-phosphor-systemd
RDEPENDS_${PN} += "virtual/obmc-gpio-monitor"
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-thermal-policy-native.bb b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-thermal-policy-native.bb
index 39831cf86..d53b4146f 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-thermal-policy-native.bb
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-thermal-policy-native.bb
@@ -1,8 +1,9 @@
SUMMARY = "Thermal policy for Witherspoon"
PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
inherit native
-inherit obmc-phosphor-license
inherit phosphor-dbus-monitor
SRC_URI += "file://thermal-policy.yaml"
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/inventory/inventory-cleanup-native.bb b/meta-ibm/meta-witherspoon/recipes-phosphor/inventory/inventory-cleanup-native.bb
index 6efde485f..80e6e6de5 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/inventory/inventory-cleanup-native.bb
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/inventory/inventory-cleanup-native.bb
@@ -1,8 +1,9 @@
SUMMARY = "Copy Witherspoon inventory cleanup yaml for inventory manager"
PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
inherit native
-inherit obmc-phosphor-license
inherit phosphor-inventory-manager
SRC_URI += "file://inventory-cleanup.yaml"
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-power-supply-policy-native.bb b/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-power-supply-policy-native.bb
index 4d234c199..563f80e30 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-power-supply-policy-native.bb
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-power-supply-policy-native.bb
@@ -1,8 +1,9 @@
SUMMARY = "Power supply policy for Witherspoon"
PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
inherit native
-inherit obmc-phosphor-license
inherit phosphor-dbus-monitor
SRC_URI += "file://power-supply-policy.yaml"
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-power-supply-sync.bb b/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-power-supply-sync.bb
index b0903e714..ea7804bcd 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-power-supply-sync.bb
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-power-supply-sync.bb
@@ -1,8 +1,9 @@
SUMMARY = "Witherspoon Power Supply Sync"
DESCRIPTION = "Synchronizes the power supplies' INPUT_HISTORY data"
PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
-inherit obmc-phosphor-license
inherit obmc-phosphor-systemd
RDEPENDS_${PN} += "virtual/obmc-gpio-monitor"
diff --git a/meta-ibm/recipes-phosphor/dbus/ibm-dbus-interfaces-mapper-config-native.bb b/meta-ibm/recipes-phosphor/dbus/ibm-dbus-interfaces-mapper-config-native.bb
index 2768caf57..381bef419 100644
--- a/meta-ibm/recipes-phosphor/dbus/ibm-dbus-interfaces-mapper-config-native.bb
+++ b/meta-ibm/recipes-phosphor/dbus/ibm-dbus-interfaces-mapper-config-native.bb
@@ -1,10 +1,11 @@
SUMMARY="Add /com/ibm namespace to phosphor-mapper"
DESCRIPTION="Add the /com/ibm path namespace and \
com.ibm interface prefix to the mapper watch list."
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
inherit phosphor-mapper
inherit native
-inherit obmc-phosphor-license
PHOSPHOR_MAPPER_SERVICE_append = " com.ibm"
PHOSPHOR_MAPPER_INTERFACE_append = " com.ibm"
OpenPOWER on IntegriCloud