summaryrefslogtreecommitdiffstats
path: root/meta-google
diff options
context:
space:
mode:
authorPatrick Venture <venture@google.com>2018-09-17 17:14:46 -0700
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-09-20 07:47:45 -0400
commit9afb671c8eb24ee37c97d20870da412fed7b2c52 (patch)
tree98a0e58f272a61f6af9bace65e4ba5b44497c298 /meta-google
parentf68c4c7ab3028e8c845d6f32bf1a4ec7a166da05 (diff)
downloadtalos-openbmc-9afb671c8eb24ee37c97d20870da412fed7b2c52.tar.gz
talos-openbmc-9afb671c8eb24ee37c97d20870da412fed7b2c52.zip
meta-google: add google-ipmi-sys package
meta-google: Add the google-ipmi-sys package. This package handles a series of OEM IPMI commands we expect to exist to provide information to the host software infrastructure. Tested: Verified the daemon and systemd target are installed when added to the obmc-phosphor-image. (From meta-google rev: 0d9aa6919ba00b3a664730f8b8a9c770a9edae81) Change-Id: I54c534680298a08743b39c384079794173ee517f Signed-off-by: Patrick Venture <venture@google.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-google')
-rw-r--r--meta-google/recipes-google/ipmi/google-ipmi-sys.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-google/recipes-google/ipmi/google-ipmi-sys.bb b/meta-google/recipes-google/ipmi/google-ipmi-sys.bb
new file mode 100644
index 000000000..b6eaaa8af
--- /dev/null
+++ b/meta-google/recipes-google/ipmi/google-ipmi-sys.bb
@@ -0,0 +1,36 @@
+HOMEPAGE = "http://github.com/openbmc/google-ipmi-sys"
+SUMMARY = "Google Sys OEM commands"
+DESCRIPTION = "Google sys OEM commands"
+
+inherit autotools pkgconfig
+inherit obmc-phosphor-license
+inherit systemd
+inherit obmc-phosphor-ipmiprovider-symlink
+
+DEPENDS += "autoconf-archive-native"
+DEPENDS += "sdbusplus"
+DEPENDS += "phosphor-logging"
+
+# We depend on this to be built first so we can build our providers.
+DEPENDS += "phosphor-ipmi-host"
+
+RDEPENDS_${PN} += "sdbusplus phosphor-dbus-interfaces"
+
+S = "${WORKDIR}/git"
+SRC_URI = "git://github.com/openbmc/google-ipmi-sys"
+SRCREV = "f9a19b80bea5987292e61b8b2aedcc3baedcaf8f"
+
+FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
+FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
+FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
+FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
+
+HOSTIPMI_PROVIDER_LIBRARY += "libsyscmds.so"
+
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE_${PN} = "gbmc-psu-hardreset.target"
+
+do_install_append() {
+ install -d ${D}${systemd_system_unitdir}
+ install -m 0644 ${S}/gbmc-psu-hardreset.target ${D}${systemd_system_unitdir}
+}
OpenPOWER on IntegriCloud