summaryrefslogtreecommitdiffstats
path: root/import-layers/yocto-poky/meta/recipes-devtools/makedevs/makedevs_1.0.1.bb
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2016-08-17 14:31:25 -0500
committerPatrick Williams <patrick@stwcx.xyz>2016-08-22 16:43:26 +0000
commit60f9d69e016b11c468c98ea75ba0a60c44afbbc4 (patch)
treeecb49581a9e41a37943c22cd9ef3f63451b20ee7 /import-layers/yocto-poky/meta/recipes-devtools/makedevs/makedevs_1.0.1.bb
parente18c61205e0234b03697129c20cc69c9b3940efc (diff)
downloadtalos-openbmc-60f9d69e016b11c468c98ea75ba0a60c44afbbc4.tar.gz
talos-openbmc-60f9d69e016b11c468c98ea75ba0a60c44afbbc4.zip
yocto-poky: Move to import-layers subdir
We are going to import additional layers, so create a subdir to hold all of the layers that we import with git-subtree. Change-Id: I6f732153a22be8ca663035c518837e3cc5ec0799 Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Diffstat (limited to 'import-layers/yocto-poky/meta/recipes-devtools/makedevs/makedevs_1.0.1.bb')
-rw-r--r--import-layers/yocto-poky/meta/recipes-devtools/makedevs/makedevs_1.0.1.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/import-layers/yocto-poky/meta/recipes-devtools/makedevs/makedevs_1.0.1.bb b/import-layers/yocto-poky/meta/recipes-devtools/makedevs/makedevs_1.0.1.bb
new file mode 100644
index 000000000..92d5870f4
--- /dev/null
+++ b/import-layers/yocto-poky/meta/recipes-devtools/makedevs/makedevs_1.0.1.bb
@@ -0,0 +1,26 @@
+SUMMARY = "Tool for creating device nodes"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833"
+SECTION = "base"
+SRC_URI = "file://makedevs.c \
+ file://COPYING.patch"
+
+S = "${WORKDIR}"
+
+FILES_${PN}_append_class-nativesdk = " ${datadir}"
+
+do_compile() {
+ ${CC} ${CFLAGS} ${LDFLAGS} -o ${S}/makedevs ${S}/makedevs.c
+}
+
+do_install() {
+ install -d ${D}${base_sbindir}
+ install -m 0755 ${S}/makedevs ${D}${base_sbindir}/makedevs
+}
+
+do_install_append_class-nativesdk() {
+ install -d ${D}${datadir}
+ install -m 644 ${COREBASE}/meta/files/device_table-minimal.txt ${D}${datadir}/
+}
+
+BBCLASSEXTEND = "native nativesdk"
OpenPOWER on IntegriCloud