summaryrefslogtreecommitdiffstats
path: root/import-layers/meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bb
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2016-08-17 15:02:23 -0500
committerPatrick Williams <patrick@stwcx.xyz>2016-08-22 16:43:34 +0000
commit8b8bc41cac34759602dc7668df9edb038839b238 (patch)
treecb5bafb877a39832d5f27534dbf796567d9d78bc /import-layers/meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bb
parentb48b7b4109868a8c0ddda090992e936e821c7ea6 (diff)
downloadtalos-openbmc-8b8bc41cac34759602dc7668df9edb038839b238.tar.gz
talos-openbmc-8b8bc41cac34759602dc7668df9edb038839b238.zip
Squashed 'import-layers/meta-raspberrypi/' content from commit 2745399
Change-Id: I8a89d81813dea98209d089ef500a403ea4da5d9d git-subtree-dir: import-layers/meta-raspberrypi git-subtree-split: 2745399f75d7564fcc586d0365ff73be47849d0e Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Diffstat (limited to 'import-layers/meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bb')
-rw-r--r--import-layers/meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/import-layers/meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bb b/import-layers/meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bb
new file mode 100644
index 000000000..b279e1551
--- /dev/null
+++ b/import-layers/meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bb
@@ -0,0 +1,39 @@
+DESCRIPTION = "Closed source binary files to help boot the ARM on the BCM2835."
+LICENSE = "Proprietary"
+
+LIC_FILES_CHKSUM = "file://LICENCE.broadcom;md5=4a4d169737c0786fb9482bb6d30401d1"
+
+inherit deploy
+
+include recipes-bsp/common/firmware.inc
+
+RDEPENDS_${PN} = "rpi-config"
+
+COMPATIBLE_MACHINE = "raspberrypi"
+
+S = "${RPIFW_S}/boot"
+
+PR = "r3"
+
+do_deploy() {
+ install -d ${DEPLOYDIR}/${PN}
+
+ for i in ${S}/*.elf ; do
+ cp $i ${DEPLOYDIR}/${PN}
+ done
+ for i in ${S}/*.dat ; do
+ cp $i ${DEPLOYDIR}/${PN}
+ done
+ for i in ${S}/*.bin ; do
+ cp $i ${DEPLOYDIR}/${PN}
+ done
+
+ # Add stamp in deploy directory
+ touch ${DEPLOYDIR}/${PN}/${PN}-${PV}.stamp
+}
+
+addtask deploy before do_package after do_install
+do_deploy[dirs] += "${DEPLOYDIR}/${PN}"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
OpenPOWER on IntegriCloud