summaryrefslogtreecommitdiffstats
path: root/libstdc++-v3/libsupc++/Makefile.am
diff options
context:
space:
mode:
authorpme <pme@138bc75d-0d04-0410-961f-82ee72b054a4>2002-12-26 06:10:35 +0000
committerpme <pme@138bc75d-0d04-0410-961f-82ee72b054a4>2002-12-26 06:10:35 +0000
commitf1c77ff0be4faefa1dc7a97fe16de1373322e8ad (patch)
tree29b72cf5b311ee7cdd1b193f946ea88ea56e84d0 /libstdc++-v3/libsupc++/Makefile.am
parent533aad177435e1e57e7113b38623e7322f4dc5d6 (diff)
downloadppe42-gcc-f1c77ff0be4faefa1dc7a97fe16de1373322e8ad.tar.gz
ppe42-gcc-f1c77ff0be4faefa1dc7a97fe16de1373322e8ad.zip
2002-12-25 Phil Edwards <pme@gcc.gnu.org>
* src/vterminate.cc: Move to... * libsupc++/vterminate.cc: ...here. New file. Replace fprintf with writestr macro. Slight reword to explanatory text. * libsupc++/eh_terminate.cc (__cxxabiv1::__terminate_handler, __cxxabiv1::__unexpected_handler): Break definitions out to... * libsupc++/eh_unex_handler.cc: ...here (new file), and... * libsupc++/eh_term_handler.cc: ...here (new file). Initialize __terminate_handler with __gnu_cxx::__verbose_terminate_handler instead of std::abort. * libsupc++/Makefile.am (sources), src/Makefile.am (sources): Update. * libsupc++/Makefile.in, src/Makefile.in: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@60505 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libstdc++-v3/libsupc++/Makefile.am')
-rw-r--r--libstdc++-v3/libsupc++/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/libstdc++-v3/libsupc++/Makefile.am b/libstdc++-v3/libsupc++/Makefile.am
index a14e0b46a25..7fd2f58e396 100644
--- a/libstdc++-v3/libsupc++/Makefile.am
+++ b/libstdc++-v3/libsupc++/Makefile.am
@@ -81,9 +81,11 @@ sources = \
eh_exception.cc \
eh_globals.cc \
eh_personality.cc \
+ eh_term_handler.cc \
eh_terminate.cc \
eh_throw.cc \
eh_type.cc \
+ eh_unex_handler.cc \
guard.cc \
new_handler.cc \
new_op.cc \
@@ -93,7 +95,8 @@ sources = \
pure.cc \
tinfo.cc \
tinfo2.cc \
- vec.cc
+ vec.cc \
+ vterminate.cc
libsupc___la_SOURCES = $(sources) $(c_sources)
libsupc__convenience_la_SOURCES = $(sources) $(c_sources)
OpenPOWER on IntegriCloud