summaryrefslogtreecommitdiffstats
path: root/libjava/Makefile.am
diff options
context:
space:
mode:
authordaney <daney@138bc75d-0d04-0410-961f-82ee72b054a4>2007-12-22 15:48:46 +0000
committerdaney <daney@138bc75d-0d04-0410-961f-82ee72b054a4>2007-12-22 15:48:46 +0000
commitc9b39a1ea1ac737b43eb80ff83dcb50049ef6d23 (patch)
tree19e8713d7afd946142d350a9ff1e1bb03716c6ee /libjava/Makefile.am
parentd454a92885eb03156445e2f44143389e3b013e59 (diff)
downloadppe42-gcc-c9b39a1ea1ac737b43eb80ff83dcb50049ef6d23.tar.gz
ppe42-gcc-c9b39a1ea1ac737b43eb80ff83dcb50049ef6d23.zip
2007-12-22 David Daney <ddaney@avtrex.com>
* doc/install.texi (disable-libgcj-bc): Document new option. 2007-12-22 David Daney <ddaney@avtrex.com> * scripts/makemake.tcl (emit_bc_rule): Use $(LIBGCJ_BC_FLAGS) instead of -findirect-dispatch -fno-indirect-classes. * configure.ac (libgcj-bc): New AC_ARG_ENABLE. (SUPPRESS_LIBGCJ_BC): New AM_CONDITIONAL. * Makefile.am (LIBGCJ_BC_FLAGS): New variable. * Makefile.in: Regenerate. * include/Makefile.in: Same. * testsuite/Makefile.in: Same. * configure: Same. * gcj/Makefile.in: Same. * sources.am: Same. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@131135 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libjava/Makefile.am')
-rw-r--r--libjava/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/libjava/Makefile.am b/libjava/Makefile.am
index d906c2ee4f0..51e4761d2a7 100644
--- a/libjava/Makefile.am
+++ b/libjava/Makefile.am
@@ -155,6 +155,12 @@ if USING_GCC
AM_CFLAGS += $(WARNINGS)
endif
+if SUPPRESS_LIBGCJ_BC
+LIBGCJ_BC_FLAGS =
+else
+LIBGCJ_BC_FLAGS = -findirect-dispatch -fno-indirect-classes
+endif
+
## Extra CFLAGS used for JNI C sources shared with GNU Classpath.
PEDANTIC_CFLAGS = -ansi -pedantic -Wall -Wno-long-long
OpenPOWER on IntegriCloud