summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 6fc724c..472dd06 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,4 +1,13 @@
sbin_PROGRAMS = phosphor-user-manager
+noinst_HEADERS = user.hpp
+
phosphor_user_manager_SOURCES = \
+ user.cpp \
mainapp.cpp
+
+phosphor_user_manager_LDFLAGS = $(SDBUSPLUS_LIBS) \
+ $(PHOSPHOR_DBUS_INTERFACES_LIBS)
+
+phosphor_user_manager_CXXFLAGS = $(SYSTEMD_CFLAGS) \
+ $(PHOSPHOR_DBUS_INTERFACES_CFLAGS)
OpenPOWER on IntegriCloud