summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorRatan Gupta <ratagupt@linux.vnet.ibm.com>2019-02-18 20:34:10 +0530
committerRatan Gupta <ratagupt@linux.vnet.ibm.com>2019-03-11 12:10:22 +0530
commit95a2931473dfa61a30e7a65606dab15ab24cd5b4 (patch)
tree489495eee9fde8aa5254dd515305214779df0301 /test/Makefile.am
parentaeaf9413a965d225d11ee1cd2c8ee9aa1f8dc862 (diff)
downloadphosphor-user-manager-95a2931473dfa61a30e7a65606dab15ab24cd5b4.tar.gz
phosphor-user-manager-95a2931473dfa61a30e7a65606dab15ab24cd5b4.zip
LDAP: Add the persistency for the "Enabled" property
This property will control that whether the LDAP service would be started or not. We are persisting this property using cereal, other properties is being persisted through nslcd.conf, nslcd doesn't give us a way to put this property under nslcd.conf. Tested By: Test the persistency of enabled property. Verified that it was getting persisted across restart/reboot. Change-Id: Id64b23b71865bac15d3be2d79abad615aa576bea Signed-off-by: Ratan Gupta <ratagupt@linux.vnet.ibm.com>
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index e3c1366..06b7bb2 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -33,7 +33,9 @@ ldap_config_test_LDFLAGS = $(utest_LDFLAGS) \
-lldap \
-lgmock
ldap_config_test_SOURCES = ldap_config_test.cpp utils_test.cpp
-ldap_config_test_LDADD = $(top_builddir)/phosphor-ldap-config/ldap_configuration.o $(top_builddir)/phosphor-ldap-config/utils.o
+ldap_config_test_LDADD = $(top_builddir)/phosphor-ldap-config/ldap_configuration.o \
+ $(top_builddir)/phosphor-ldap-config/utils.o \
+ $(top_builddir)/phosphor-ldap-config/ldap_serialize.o
check_PROGRAMS += ldap_mapper_test
ldap_mapper_test_CPPFLAGS = $(utest_CPPFLAGS)
OpenPOWER on IntegriCloud