summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorVishwanatha Subbanna <vishwa@linux.vnet.ibm.com>2017-09-06 11:29:37 +0530
committerVishwanatha Subbanna <vishwa@linux.vnet.ibm.com>2017-09-06 11:29:37 +0530
commit8a89b53bf014d0844dfd85b2327853037d1e2cb7 (patch)
tree9b613a35dd16903007935b1b3d6c9b5c77a3506e /configure.ac
parentf3dfd3221245d2f398a10c36c3afe88a11df11f3 (diff)
downloadphosphor-user-manager-8a89b53bf014d0844dfd85b2327853037d1e2cb7.tar.gz
phosphor-user-manager-8a89b53bf014d0844dfd85b2327853037d1e2cb7.zip
Put initial skeleton code of user manager
Change-Id: I4f95a8baf9348d9ed9b7e8b6b53a7a4e538b045e Signed-off-by: Vishwanatha Subbanna <vishwa@linux.vnet.ibm.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..59dfe11
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,24 @@
+# Initialization
+AC_PREREQ([2.69])
+AC_INIT([phosphor-user-manager], [1.0], [https://github.com/openbmc/phosphor-user-manager/issues])
+AC_LANG([C++])
+AC_CONFIG_HEADERS([config.h])
+AM_INIT_AUTOMAKE([subdir-objects -Wall -Werror foreign dist-xz])
+AM_SILENT_RULES([yes])
+
+# Checks for programs.
+AC_PROG_CXX
+AC_PROG_INSTALL
+AC_PROG_MAKE_SET
+
+
+# Checks for typedefs, structures, and compiler characteristics.
+AX_CXX_COMPILE_STDCXX_14([noext])
+AX_APPEND_COMPILE_FLAGS([-Wall -Werror], [CXXFLAGS])
+
+# For libtools
+LT_INIT
+
+# Create configured output
+AC_CONFIG_FILES([Makefile])
+AC_OUTPUT
OpenPOWER on IntegriCloud