summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRichard Marian Thomaiyar <richard.marian.thomaiyar@linux.intel.com>2018-05-24 10:49:10 +0530
committerRichard Marian Thomaiyar <richard.marian.thomaiyar@linux.intel.com>2018-09-03 14:16:20 +0530
commit9f630d9eb0ce1c103532a4304ea080066199094e (patch)
treeb102a63e2617d928ce82215b07637336ded2db7d /Makefile.am
parent10eb23f8d64d197dade920178b193c1979235156 (diff)
downloadphosphor-user-manager-9f630d9eb0ce1c103532a4304ea080066199094e.tar.gz
phosphor-user-manager-9f630d9eb0ce1c103532a4304ea080066199094e.zip
Basic support for User manager service
Basic support for User Manager service methods are implemented. Change-Id: Id42432ec6dd421b99971268add931dcd70876f7c Signed-off-by: Richard Marian Thomaiyar <richard.marian.thomaiyar@linux.intel.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 11 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 5d5e14f..b8b753d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,18 +1,26 @@
sbin_PROGRAMS = phosphor-user-manager
-noinst_HEADERS = user.hpp
+noinst_HEADERS = user.hpp user_mgr.hpp users.hpp
phosphor_user_manager_SOURCES = \
user.cpp \
- mainapp.cpp
+ mainapp.cpp \
+ user_mgr.cpp \
+ users.cpp
phosphor_user_manager_LDFLAGS = $(SDBUSPLUS_LIBS) \
$(PHOSPHOR_DBUS_INTERFACES_LIBS) \
$(PHOSPHOR_LOGGING_LIBS) \
+ $(BOOST_CPPFLAGS) \
-lcrypt \
-lstdc++fs
phosphor_user_manager_CXXFLAGS = $(SYSTEMD_CFLAGS) \
$(PHOSPHOR_DBUS_INTERFACES_CFLAGS) \
- $(PHOSPHOR_LOGGING_CFLAGS)
+ $(PHOSPHOR_LOGGING_CFLAGS) \
+ $(BOOST_CPPFLAGS) \
+ -DBOOST_ALL_NO_LIB \
+ -DBOOST_SYSTEM_NO_DEPRECATED \
+ -DBOOST_ERROR_CODE_HEADER_ONLY
+
SUBDIRS = . test
OpenPOWER on IntegriCloud