summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDeepak Kodihalli <dkodihal@in.ibm.com>2017-05-16 23:53:40 -0500
committerDeepak Kodihalli <dkodihal@in.ibm.com>2017-05-26 00:17:00 -0500
commit5de0957ccc5ba51bba375d2434cd3420b7a2c3af (patch)
treeeb3cd0cd22ff0695497362241b3b8da70ed2dd00 /configure.ac
parent3b8d055ca761a68c74dad01a306f238674d71878 (diff)
downloadphosphor-settingsd-5de0957ccc5ba51bba375d2434cd3420b7a2c3af.tar.gz
phosphor-settingsd-5de0957ccc5ba51bba375d2434cd3420b7a2c3af.zip
Add settings application
Implement settings d-bus interfaces. Define a settings policy file (this commit checks in an example YAML based policy), based on which code for a settings manager will be generated via a python script. This settings manager composes and places desired settings objects on the bus. The policy file can be supplied by a system specific bitbake recipe. Resolves openbmc/openbmc#1487. Change-Id: Ice0d3b319d9466824cef323a6915eb20ca5cae5c Signed-off-by: Deepak Kodihalli <dkodihal@in.ibm.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac42
1 files changed, 42 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..6b3191d
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,42 @@
+AC_PREREQ([2.69])
+AC_INIT([phosphor-settingsd], [1.0], [https://github.com/openbmc/phosphor-settingsd/issues])
+AC_LANG([C++])
+AC_CONFIG_HEADERS([config.h])
+AM_INIT_AUTOMAKE([subdir-objects -Wall -Werror foreign dist-xz])
+AM_SILENT_RULES([yes])
+
+AC_PROG_CXX
+AM_PROG_AR
+AC_PROG_INSTALL
+AC_PROG_MAKE_SET
+AM_PATH_PYTHON([2.7], [AC_SUBST([PYTHON], [echo "$PYTHON"])], [AC_MSG_ERROR(
+ [Could not find python-2.7 installed...python-2.7 is required])])
+
+PKG_CHECK_MODULES([PHOSPHOR_DBUS_INTERFACES], [phosphor-dbus-interfaces],,\
+ AC_MSG_ERROR(["Requires phosphor-dbus-interfaces package."]))
+PKG_CHECK_MODULES([SDBUSPLUS], [sdbusplus],,
+ AC_MSG_ERROR(["Requires sdbusplus package."]))
+
+LT_INIT
+
+AX_CXX_COMPILE_STDCXX_14([noext])
+AX_APPEND_COMPILE_FLAGS([-Wall -Werror], [CXXFLAGS])
+
+AC_ARG_VAR(SETTINGS_BUSNAME, [The Dbus busname to own])
+AS_IF([test "x$SETTINGS_BUSNAME" == "x"],\
+ [SETTINGS_BUSNAME="xyz.openbmc_project.Settings"])
+AC_DEFINE_UNQUOTED([SETTINGS_BUSNAME], ["$SETTINGS_BUSNAME"],\
+ [The DBus busname to own])
+
+AC_ARG_VAR(SETTINGS_ROOT, [The settings Dbus root])
+AS_IF([test "x$SETTINGS_ROOT" == "x"],\
+ [SETTINGS_ROOT="/xyz/openbmc_project/settings"])
+AC_DEFINE_UNQUOTED([SETTINGS_ROOT], ["$SETTINGS_ROOT"],\
+ [The settings Dbus root])
+
+AS_IF([test "x$SETTINGS_YAML" == "x"], [SETTINGS_YAML="settings_example.yaml"])
+SETTINGSGEN="$PYTHON $srcdir/settings.py -i $SETTINGS_YAML"
+AC_SUBST(SETTINGSGEN)
+
+AC_CONFIG_FILES([Makefile])
+AC_OUTPUT
OpenPOWER on IntegriCloud