summaryrefslogtreecommitdiffstats
path: root/module/setup.py
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2016-08-29 15:53:25 -0400
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2016-08-30 08:46:57 -0400
commit2c6fc760919cc214413874d60489e3643b639692 (patch)
tree65e57c81daf4a13fabc292c4e43eede7a472134f /module/setup.py
parent803c6f1be7f589043c817a2b00fac5b0af93d200 (diff)
downloadphosphor-rest-server-2c6fc760919cc214413874d60489e3643b639692.tar.gz
phosphor-rest-server-2c6fc760919cc214413874d60489e3643b639692.zip
Split server and application
Provide the REST server as a python module, enabling it to be hosted by any WSGI provider. Provide a Rocket startup script with configurable WSGI application. Change-Id: I1a9c25b10c33b08dfb8f60dc6c33aaf727562a9f Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'module/setup.py')
-rw-r--r--module/setup.py7
1 files changed, 7 insertions, 0 deletions
diff --git a/module/setup.py b/module/setup.py
new file mode 100644
index 0000000..dd2ff3b
--- /dev/null
+++ b/module/setup.py
@@ -0,0 +1,7 @@
+from distutils.core import setup
+
+setup(
+ name='phosphor-rest-dbus',
+ version='1.0',
+ py_modules=['obmc.wsgi.apps.rest_dbus'],
+ )
OpenPOWER on IntegriCloud