summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAndrew Jeffery <andrew@aj.id.au>2017-04-13 16:09:19 +0930
committerAndrew Jeffery <andrew@aj.id.au>2017-04-26 07:46:50 +0000
commitb34cc542f714f63e6467c74b8f3da99a301e1cfc (patch)
treea5017a7b7407a31b5828efb4635f20c547110f3b /Makefile.am
parent9d4b8883a7a5671476f1be1a93560a97716a311e (diff)
downloadphosphor-mboxd-b34cc542f714f63e6467c74b8f3da99a301e1cfc.tar.gz
phosphor-mboxd-b34cc542f714f63e6467c74b8f3da99a301e1cfc.zip
test: Add read_window_cycle
Change-Id: Iaa967b7e0732ebc0322ea89e74861a5bedb34867 Signed-off-by: Andrew Jeffery <andrew@aj.id.au>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index e4d5473..735efd8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -86,6 +86,9 @@ test_write_window_dirty_erase_SOURCES = test/write_window_dirty_erase.c \
test_invalid_command_SOURCES = test/invalid_command.c \
$(TEST_MBOX_SRCS) $(TEST_MOCK_SRCS)
+test_read_window_cycle_SOURCES = test/read_window_cycle.c \
+ $(TEST_MBOX_SRCS) $(TEST_MOCK_SRCS)
+
check_PROGRAMS = test/sanity \
test/copy_flash \
test/erase_flash \
@@ -109,6 +112,7 @@ check_PROGRAMS = test/sanity \
test/read_window_write_flush \
test/read_window_mark_write_erased \
test/write_window_dirty_erase \
- test/invalid_command
+ test/invalid_command \
+ test/read_window_cycle
TESTS = $(check_PROGRAMS)
OpenPOWER on IntegriCloud