summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDeepak Kodihalli <dkodihal@in.ibm.com>2017-07-13 12:04:06 -0500
committerDeepak Kodihalli <dkodihal@in.ibm.com>2017-07-18 22:54:23 -0500
commitabd52a78941e91bb603772a252c3a98477fec44d (patch)
tree704e1406c8d3718db33259b2af1b17d3c94d85e1 /Makefile.am
parent96acf160aec88fb754606baa361b4407de066724 (diff)
downloadphosphor-mboxd-abd52a78941e91bb603772a252c3a98477fec44d.tar.gz
phosphor-mboxd-abd52a78941e91bb603772a252c3a98477fec44d.zip
vpnor: implement init_flash_dev
The vpnor version needs to set the erase block size as 4K. That's the size hostboot expects in the FFS structure. This change also requires moving code from mboxd_flash.c to mboxd_flash_physical.c, else there will be 3 symbols per flash function. It should suffice to just have mboxd_flash_physical.c and mboxd_flash_virtual.cpp. Change-Id: I35442a0c1dbee7f66b278cbf094be78e870b6c86 Signed-off-by: Deepak Kodihalli <dkodihal@in.ibm.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 0 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index 4e59529..59146ba 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -5,7 +5,6 @@ mboxd_SOURCES = \
mboxd.c \
common.c \
mboxd_dbus.c \
- mboxd_flash.c \
mboxd_lpc.c \
mboxd_msg.c \
mboxd_windows.c \
@@ -42,21 +41,18 @@ test_sanity_SOURCES = test/sanity.c
test_copy_flash_SOURCES = \
test/copy_flash.c \
- mboxd_flash.c \
mboxd_flash_physical.c \
common.c mtd.c \
test/tmpf.c
test_erase_flash_SOURCES = \
test/erase_flash.c \
- mboxd_flash.c \
mboxd_flash_physical.c \
common.c \
test/tmpf.c
test_write_flash_SOURCES = \
test/write_flash.c \
- mboxd_flash.c \
mboxd_flash_physical.c \
common.c \
test/tmpf.c
@@ -65,7 +61,6 @@ TEST_MBOX_SRCS = \
mboxd_msg.c \
mboxd_windows.c \
mboxd_lpc.c \
- mboxd_flash.c \
common.c \
mboxd_flash_physical.c
@@ -153,7 +148,6 @@ test_create_read_window_vpnor_SOURCES = \
mboxd_msg.c \
mboxd_windows.c \
mboxd_lpc.c \
- mboxd_flash.c \
mboxd_pnor_partition_table.cpp \
mboxd_flash_virtual.cpp \
pnor_partition.cpp \
@@ -166,7 +160,6 @@ test_create_read_window_vpnor_LDADD = -lstdc++fs \
test_write_flash_vpnor_SOURCES = \
$(TEST_MBOX_VPNOR_SRCS) \
- mboxd_flash.c \
mboxd_pnor_partition_table.cpp \
mboxd_flash_virtual.cpp \
mtd.c \
OpenPOWER on IntegriCloud