summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDeepak Kodihalli <dkodihal@in.ibm.com>2017-07-11 23:17:19 -0500
committerPatrick Williams <patrick@stwcx.xyz>2017-07-19 22:58:34 +0000
commit8a89969d635a8ac8f7b21bb673ec03a19d76cd4d (patch)
treec9669733b9ed217139a7b1aeafd41071eca9b7f8 /Makefile.am
parentd1d7930d5d86e7a537fa46e1137bb4131ee52c07 (diff)
downloadphosphor-mboxd-8a89969d635a8ac8f7b21bb673ec03a19d76cd4d.tar.gz
phosphor-mboxd-8a89969d635a8ac8f7b21bb673ec03a19d76cd4d.zip
vpnor: add API to get partition entry by name
Change-Id: I1f86c646c6629a6a42788821e469d36f55c92264 Signed-off-by: Deepak Kodihalli <dkodihal@in.ibm.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 59146ba..af44432 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -141,7 +141,10 @@ test_create_pnor_partition_table_SOURCES = \
$(TEST_MBOX_VPNOR_SRCS) \
test/create_pnor_partition_table.cpp
test_create_pnor_partition_table_LDFLAGS = $(OESDK_TESTCASE_FLAGS)
-test_create_pnor_partition_table_LDADD = -lstdc++fs
+test_create_pnor_partition_table_LDADD = -lstdc++fs \
+ $(SDBUSPLUS_LIBS) \
+ $(PHOSPHOR_LOGGING_LIBS) \
+ $(PHOSPHOR_DBUS_INTERFACES_LIBS)
test_create_read_window_vpnor_SOURCES = \
$(TEST_MBOX_VPNOR_SRCS) $(TEST_MOCK_SRCS) \
OpenPOWER on IntegriCloud