summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDeepak Kodihalli <dkodihal@in.ibm.com>2017-05-01 06:36:02 -0500
committerDeepak Kodihalli <dkodihal@in.ibm.com>2017-06-27 08:40:32 -0500
commit6c2fa90d498acff8a1c319c883c3bbf89282bdfe (patch)
treec853936772e426629f5153c71bcf1ba4e814cf43 /Makefile.am
parentb6a446f9070e6a8f044227ed74269aeb627cd1af (diff)
downloadphosphor-mboxd-6c2fa90d498acff8a1c319c883c3bbf89282bdfe.tar.gz
phosphor-mboxd-6c2fa90d498acff8a1c319c883c3bbf89282bdfe.zip
msg: handle partition table read request
Map host's request to read the flash at offset less than the partition table length as a request to read the pnor partition table. Resolves openbmc/openbmc#1439. Change-Id: I0f5b98f073d983b0d4749b0aba84b37d7f42f884 Signed-off-by: Deepak Kodihalli <dkodihal@in.ibm.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 8c779f8..78aeffa 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -14,8 +14,10 @@ mboxd_LDFLAGS = $(LIBSYSTEMD_LIBS)
mboxd_CFLAGS = $(LIBSYSTEMD_CFLAGS)
if VIRTUAL_PNOR_ENABLED
-mboxd_SOURCES += pnor_partition_table.cpp mboxd_pnor_partition_table.cpp
+mboxd_SOURCES += pnor_partition_table.cpp mboxd_pnor_partition_table.cpp mboxd_flash_virtual.cpp
mboxd_LDFLAGS += -lstdc++fs
+else
+mboxd_SOURCES += mboxd_flash_physical.c
endif
mboxctl_SOURCES = mboxctl.c
@@ -31,13 +33,13 @@ AM_CXXFLAGS = $(CODE_COVERAGE_CXXFLAGS)
test_sanity_SOURCES = test/sanity.c
-test_copy_flash_SOURCES = test/copy_flash.c mboxd_flash.c common.c mtd.c test/tmpf.c
+test_copy_flash_SOURCES = test/copy_flash.c mboxd_flash.c mboxd_flash_physical.c common.c mtd.c test/tmpf.c
test_erase_flash_SOURCES = test/erase_flash.c mboxd_flash.c common.c test/tmpf.c
test_write_flash_SOURCES = test/write_flash.c mboxd_flash.c common.c test/tmpf.c
-TEST_MBOX_SRCS = mboxd_msg.c mboxd_windows.c mboxd_lpc.c mboxd_flash.c common.c
+TEST_MBOX_SRCS = mboxd_msg.c mboxd_windows.c mboxd_lpc.c mboxd_flash.c common.c mboxd_flash_physical.c
TEST_MOCK_SRCS = test/tmpf.c test/mbox.c test/system.c
test_get_mbox_info_v2_SOURCES = test/get_mbox_info_v2.c \
OpenPOWER on IntegriCloud