summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAndrew Jeffery <andrew@aj.id.au>2018-02-21 21:36:59 +1030
committerAndrew Jeffery <andrew@aj.id.au>2018-03-24 13:59:32 +1030
commit5345c51ebff0c86f13bcc933c952b588c3b4a1ee (patch)
treea6a9ebd23125e09b3e23605edbec9d0fd58a85ff /Makefile.am
parent7f9c343a4f62abb9ea6eb64974b19ff7b6c879f2 (diff)
downloadphosphor-mboxd-5345c51ebff0c86f13bcc933c952b588c3b4a1ee.tar.gz
phosphor-mboxd-5345c51ebff0c86f13bcc933c952b588c3b4a1ee.zip
test: Move tests to a separate Makefile fragment
Change-Id: I46d5b165ed668ace67ae237b16d65a24586dd87d Signed-off-by: Andrew Jeffery <andrew@aj.id.au>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am179
1 files changed, 1 insertions, 178 deletions
diff --git a/Makefile.am b/Makefile.am
index f182f1a..b1d86aa 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -34,183 +34,6 @@ mboxctl_CFLAGS = $(LIBSYSTEMD_CFLAGS)
@CODE_COVERAGE_RULES@
-AM_LIBS = $(CODE_COVERAGE_LIBS)
-AM_CPPFLAGS = $(CODE_COVERAGE_CPPFLAGS)
-AM_CFLAGS = $(CODE_COVERAGE_CFLAGS)
-AM_CXXFLAGS = $(CODE_COVERAGE_CXXFLAGS)
-
-test_sanity_SOURCES = test/sanity.c
-
-test_copy_flash_SOURCES = \
- test/copy_flash.c \
- mboxd_flash_physical.c \
- common.c mtd.c \
- test/tmpf.c
-
-test_erase_flash_SOURCES = \
- test/erase_flash.c \
- mboxd_flash_physical.c \
- common.c \
- test/tmpf.c
-
-test_write_flash_SOURCES = \
- test/write_flash.c \
- mboxd_flash_physical.c \
- common.c \
- test/tmpf.c
-
-TEST_MBOX_SRCS = \
- mboxd_msg.c \
- mboxd_windows.c \
- mboxd_lpc.c \
- mboxd_lpc_physical.c \
- common.c \
- mboxd_flash_physical.c
-
-TEST_MOCK_SRCS = test/tmpf.c test/mbox.c test/system.c
-
-test_get_mbox_info_v2_SOURCES = test/get_mbox_info_v2.c \
- $(TEST_MBOX_SRCS) $(TEST_MOCK_SRCS)
-
-test_reset_state_SOURCES = test/reset_state.c \
- $(TEST_MBOX_SRCS) $(TEST_MOCK_SRCS)
-
-test_get_flash_info_v2_SOURCES = test/get_flash_info_v2.c \
- $(TEST_MBOX_SRCS) $(TEST_MOCK_SRCS)
-
-test_create_read_window_v2_SOURCES = test/create_read_window_v2.c \
- $(TEST_MBOX_SRCS) $(TEST_MOCK_SRCS)
-
-test_create_write_window_v2_SOURCES = test/create_write_window_v2.c \
- $(TEST_MBOX_SRCS) $(TEST_MOCK_SRCS)
-
-test_close_window_v2_SOURCES = test/close_window_v2.c \
- $(TEST_MBOX_SRCS) $(TEST_MOCK_SRCS)
-
-test_mark_write_dirty_v2_SOURCES = test/mark_write_dirty_v2.c \
- $(TEST_MBOX_SRCS) $(TEST_MOCK_SRCS)
-
-test_write_flush_v2_SOURCES = test/write_flush_v2.c \
- $(TEST_MBOX_SRCS) $(TEST_MOCK_SRCS)
-
-test_mark_write_erased_v2_SOURCES = test/mark_write_erased_v2.c \
- $(TEST_MBOX_SRCS) $(TEST_MOCK_SRCS)
-
-test_bmc_event_ack_v2_SOURCES = test/bmc_event_ack_v2.c \
- $(TEST_MBOX_SRCS) $(TEST_MOCK_SRCS)
-
-test_create_oversize_window_SOURCES = test/create_oversize_window.c \
- $(TEST_MBOX_SRCS) $(TEST_MOCK_SRCS)
-
-test_create_zero_size_window_SOURCES = test/create_zero_size_window.c \
- $(TEST_MBOX_SRCS) $(TEST_MOCK_SRCS)
-
-test_implicit_flush_SOURCES = test/implicit_flush.c \
- $(TEST_MBOX_SRCS) $(TEST_MOCK_SRCS)
-
-test_request_high_version_SOURCES = test/request_high_version.c \
- $(TEST_MBOX_SRCS) $(TEST_MOCK_SRCS)
-
-test_request_low_version_SOURCES = test/request_low_version.c \
- $(TEST_MBOX_SRCS) $(TEST_MOCK_SRCS)
-
-test_mark_read_dirty_SOURCES = test/mark_read_dirty.c \
- $(TEST_MBOX_SRCS) $(TEST_MOCK_SRCS)
-
-test_read_window_write_flush_SOURCES = test/read_window_write_flush.c \
- $(TEST_MBOX_SRCS) $(TEST_MOCK_SRCS)
-
-test_read_window_mark_write_erased_SOURCES = test/read_window_mark_write_erased.c \
- $(TEST_MBOX_SRCS) $(TEST_MOCK_SRCS)
-
-test_write_window_dirty_erase_SOURCES = test/write_window_dirty_erase.c \
- $(TEST_MBOX_SRCS) $(TEST_MOCK_SRCS)
-
-test_invalid_command_SOURCES = test/invalid_command.c \
- $(TEST_MBOX_SRCS) $(TEST_MOCK_SRCS)
-
-test_read_window_cycle_SOURCES = test/read_window_cycle.c \
- $(TEST_MBOX_SRCS) $(TEST_MOCK_SRCS)
-
-test_sequence_numbers_SOURCES = test/sequence_numbers.c \
- $(TEST_MBOX_SRCS) $(TEST_MOCK_SRCS)
-
-test_get_mbox_info_v2_timeout_SOURCES = test/get_mbox_info_v2_timeout.c \
- $(TEST_MBOX_SRCS) $(TEST_MOCK_SRCS)
-
-TEST_MBOX_VPNOR_SRCS = common.c pnor_partition_table.cpp
-
-test_create_pnor_partition_table_SOURCES = \
- $(TEST_MBOX_VPNOR_SRCS) \
- test/create_pnor_partition_table.cpp
-test_create_pnor_partition_table_LDFLAGS = $(OESDK_TESTCASE_FLAGS)
-test_create_pnor_partition_table_LDADD = -lstdc++fs \
- $(SDBUSPLUS_LIBS) \
- $(PHOSPHOR_LOGGING_LIBS) \
- $(PHOSPHOR_DBUS_INTERFACES_LIBS)
-
-test_create_read_window_vpnor_SOURCES = \
- $(TEST_MBOX_VPNOR_SRCS) $(TEST_MOCK_SRCS) \
- mboxd_msg.c \
- mboxd_windows.c \
- mboxd_lpc.c \
- mboxd_lpc_virtual.cpp \
- mboxd_pnor_partition_table.cpp \
- mboxd_flash_virtual.cpp \
- pnor_partition.cpp \
- test/create_read_window_vpnor.cpp
-test_create_read_window_vpnor_LDFLAGS = $(OESDK_TESTCASE_FLAGS)
-test_create_read_window_vpnor_LDADD = -lstdc++fs \
- $(SDBUSPLUS_LIBS) \
- $(PHOSPHOR_LOGGING_LIBS) \
- $(PHOSPHOR_DBUS_INTERFACES_LIBS)
-
-test_write_flash_vpnor_SOURCES = \
- $(TEST_MBOX_VPNOR_SRCS) \
- mboxd_pnor_partition_table.cpp \
- mboxd_flash_virtual.cpp \
- mtd.c \
- pnor_partition.cpp \
- test/write_flash_vpnor.cpp
-test_write_flash_vpnor_LDFLAGS = $(OESDK_TESTCASE_FLAGS)
-test_write_flash_vpnor_LDADD = -lstdc++fs \
- $(SDBUSPLUS_LIBS) \
- $(PHOSPHOR_LOGGING_LIBS) \
- $(PHOSPHOR_DBUS_INTERFACES_LIBS)
-
-check_PROGRAMS = test/sanity \
- test/copy_flash \
- test/erase_flash \
- test/write_flash \
- test/get_mbox_info_v2 \
- test/reset_state \
- test/get_flash_info_v2 \
- test/create_read_window_v2 \
- test/create_write_window_v2 \
- test/close_window_v2 \
- test/mark_write_dirty_v2 \
- test/write_flush_v2 \
- test/mark_write_erased_v2 \
- test/bmc_event_ack_v2 \
- test/create_oversize_window \
- test/create_zero_size_window \
- test/implicit_flush \
- test/request_high_version \
- test/request_low_version \
- test/mark_read_dirty \
- test/read_window_write_flush \
- test/read_window_mark_write_erased \
- test/write_window_dirty_erase \
- test/invalid_command \
- test/read_window_cycle \
- test/sequence_numbers \
- test/get_mbox_info_v2_timeout
-
-if VIRTUAL_PNOR_ENABLED
-check_PROGRAMS += \
- test/create_pnor_partition_table \
- test/create_read_window_vpnor \
- test/write_flash_vpnor
-endif
+include test/Makefile.am.include
TESTS = $(check_PROGRAMS)
OpenPOWER on IntegriCloud