summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRatan Gupta <ratagupt@in.ibm.com>2017-05-11 08:58:19 +0530
committerRatan Gupta <ratagupt@in.ibm.com>2017-06-29 00:57:46 +0530
commit3214b5137d5152f1201d1c551c8bacacac5fd10e (patch)
treed4a6b35cc3ac6c5a264fe9289069e1feda256be2 /Makefile.am
parent8441a3958a70ea9980adc02bc85af28dc5ac7f92 (diff)
downloadphosphor-mboxd-3214b5137d5152f1201d1c551c8bacacac5fd10e.tar.gz
phosphor-mboxd-3214b5137d5152f1201d1c551c8bacacac5fd10e.zip
test: read window from partition file
Resolves openbmc/openbmc#1440 Change-Id: I8e6ae35e4c5ba2936a578349e6cea464de6ab40d Signed-off-by: Ratan Gupta <ratagupt@in.ibm.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am21
1 files changed, 17 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index ce9b119..3c01879 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -111,13 +111,26 @@ test_sequence_numbers_SOURCES = test/sequence_numbers.c \
test_get_mbox_info_v2_timeout_SOURCES = test/get_mbox_info_v2_timeout.c \
$(TEST_MBOX_SRCS) $(TEST_MOCK_SRCS)
+TEST_MBOX_VPNOR_SRCS = common.c pnor_partition_table.cpp
+
test_create_pnor_partition_table_SOURCES = \
- test/create_pnor_partition_table.cpp \
- common.c \
- pnor_partition_table.cpp
+ $(TEST_MBOX_VPNOR_SRCS) \
+ test/create_pnor_partition_table.cpp
test_create_pnor_partition_table_LDFLAGS = $(OESDK_TESTCASE_FLAGS)
test_create_pnor_partition_table_LDADD = -lstdc++fs
+test_create_read_window_vpnor_SOURCES = \
+ $(TEST_MBOX_VPNOR_SRCS) $(TEST_MOCK_SRCS) \
+ mboxd_msg.c \
+ mboxd_windows.c \
+ mboxd_lpc.c \
+ mboxd_flash.c \
+ mboxd_pnor_partition_table.cpp \
+ mboxd_flash_virtual.cpp \
+ test/create_read_window_vpnor.cpp
+test_create_read_window_vpnor_LDFLAGS = $(OESDK_TESTCASE_FLAGS)
+test_create_read_window_vpnor_LDADD = -lstdc++fs
+
check_PROGRAMS = test/sanity \
test/copy_flash \
test/erase_flash \
@@ -147,7 +160,7 @@ check_PROGRAMS = test/sanity \
test/get_mbox_info_v2_timeout
if VIRTUAL_PNOR_ENABLED
-check_PROGRAMS += test/create_pnor_partition_table
+check_PROGRAMS += test/create_pnor_partition_table test/create_read_window_vpnor
endif
TESTS = $(check_PROGRAMS)
OpenPOWER on IntegriCloud