summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 0db1650..30e5472 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -7,7 +7,8 @@ check_PROGRAMS = \
serialization_test_path \
serialization_test_properties \
remote_logging_test_address \
- remote_logging_test_port
+ remote_logging_test_port \
+ remote_logging_test_config
test_cppflags = \
-Igtest \
@@ -78,3 +79,11 @@ remote_logging_test_port_LDADD = $(remote_logging_test_ldadd)
remote_logging_test_port_LDFLAGS = \
$(test_ldflags) \
-lstdc++fs
+
+remote_logging_test_config_CPPFLAGS = $(test_cppflags)
+remote_logging_test_config_CXXFLAGS = $(test_cxxflags)
+remote_logging_test_config_SOURCES = remote_logging_test_config.cpp
+remote_logging_test_config_LDADD = $(remote_logging_test_ldadd)
+remote_logging_test_config_LDFLAGS = \
+ $(test_ldflags) \
+ -lstdc++fs
OpenPOWER on IntegriCloud