summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorDeepak Kodihalli <dkodihal@in.ibm.com>2018-08-30 05:05:46 -0500
committerDeepak Kodihalli <dkodihal@in.ibm.com>2018-08-31 04:41:24 -0500
commit834dcf100f87966bdcb322afda4c23fa4135c021 (patch)
tree54afe01da2c6f29b73f589821e7ad6927c6c1359 /test/Makefile.am
parent2ce7b2c37e634da4e38e63f560d04707506746a2 (diff)
downloadphosphor-logging-834dcf100f87966bdcb322afda4c23fa4135c021.tar.gz
phosphor-logging-834dcf100f87966bdcb322afda4c23fa4135c021.zip
phosphor-rsyslog-conf: add unit tests
Add tests related to setting remote server IP address and port. Change-Id: I35ac539a8316d34245ee6b1abcb9f48c1ebe5095 Signed-off-by: Deepak Kodihalli <dkodihal@in.ibm.com>
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am21
1 files changed, 20 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 68ad467..0db1650 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -5,7 +5,9 @@ TESTS = $(check_PROGRAMS)
check_PROGRAMS = \
elog_errorwrap_test \
serialization_test_path \
- serialization_test_properties
+ serialization_test_properties \
+ remote_logging_test_address \
+ remote_logging_test_port
test_cppflags = \
-Igtest \
@@ -35,6 +37,7 @@ test_ldadd = \
$(top_builddir)/elog-lookup.o \
$(top_builddir)/elog-process-metadata.o
+remote_logging_test_ldadd = $(top_builddir)/phosphor-rsyslog-config/server-conf.o
elog_errorwrap_test_CPPFLAGS = $(test_cppflags)
elog_errorwrap_test_CXXFLAGS = $(test_cxxflags)
@@ -59,3 +62,19 @@ serialization_test_properties_LDADD = $(test_ldadd)
serialization_test_properties_LDFLAGS = \
$(test_ldflags) \
-lstdc++fs
+
+remote_logging_test_address_CPPFLAGS = $(test_cppflags)
+remote_logging_test_address_CXXFLAGS = $(test_cxxflags)
+remote_logging_test_address_SOURCES = remote_logging_test_address.cpp
+remote_logging_test_address_LDADD = $(remote_logging_test_ldadd)
+remote_logging_test_address_LDFLAGS = \
+ $(test_ldflags) \
+ -lstdc++fs
+
+remote_logging_test_port_CPPFLAGS = $(test_cppflags)
+remote_logging_test_port_CXXFLAGS = $(test_cxxflags)
+remote_logging_test_port_SOURCES = remote_logging_test_port.cpp
+remote_logging_test_port_LDADD = $(remote_logging_test_ldadd)
+remote_logging_test_port_LDFLAGS = \
+ $(test_ldflags) \
+ -lstdc++fs
OpenPOWER on IntegriCloud