summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorDeepak Kodihalli <dkodihal@in.ibm.com>2017-06-14 03:56:12 -0500
committerPatrick Williams <patrick@stwcx.xyz>2017-06-26 02:33:45 +0000
commit707a3e1b4d224ca273c67fcc1dba2a21d6d8e2c5 (patch)
tree0945c2715ed25f2069501d3cb9ee63d05251e390 /test/Makefile.am
parent3388799db3945b038ff95928067c30f210f68d53 (diff)
downloadphosphor-logging-707a3e1b4d224ca273c67fcc1dba2a21d6d8e2c5.tar.gz
phosphor-logging-707a3e1b4d224ca273c67fcc1dba2a21d6d8e2c5.zip
serialization: add tests
Resolves openbmc/openbmc#1684. Change-Id: Ia554147001e51b05fe8692ae0b39e3efaf481130 Signed-off-by: Deepak Kodihalli <dkodihal@in.ibm.com>
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am63
1 files changed, 54 insertions, 9 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index ee0881b..c9946d7 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -1,12 +1,57 @@
-# gtest unit tests which run during a 'make check'
-check_PROGRAMS =
+AM_CPPFLAGS = -I${top_srcdir}
-# Run all 'check' test programs
TESTS = $(check_PROGRAMS)
-# Basic test suite for elog interfaces
-check_PROGRAMS += elog_unittest
-elog_unittest_CPPFLAGS = -Igtest $(GTEST_CPPFLAGS)
-elog_unittest_CXXFLAGS = $(PTHREAD_CFLAGS)
-elog_unittest_LDFLAGS = -lgtest_main -lgtest $(PTHREAD_LIBS) $(OESDK_TESTCASE_FLAGS)
-elog_unittest_SOURCES = elog_unittest.cpp \ No newline at end of file
+check_PROGRAMS = \
+ elog_unittest \
+ serialization_test_path \
+ serialization_test_properties
+
+test_cppflags = \
+ -Igtest \
+ $(GTEST_CPPFLAGS) \
+ $(AM_CPPFLAGS) \
+ $(PHOSPHOR_DBUS_INTERFACES_CFLAGS) \
+ $(SDBUSPLUS_CFLAGS)
+
+test_cxxflags = \
+ $(PTHREAD_CFLAGS)
+
+test_ldflags = \
+ -lgtest_main -lgtest \
+ $(PTHREAD_LIBS) \
+ $(OESDK_TESTCASE_FLAGS) \
+ $(PHOSPHOR_DBUS_INTERFACES_LIBS) \
+ $(SDBUSPLUS_LIBS)
+
+test_ldadd = \
+ $(top_builddir)/elog_serialize.o \
+ $(top_builddir)/elog_entry.o \
+ $(top_builddir)/log_manager.o \
+ $(top_builddir)/org.openbmc.Associations.o \
+ $(top_builddir)/xyz/openbmc_project/Logging/Internal/Manager/server.o \
+ $(top_builddir)/elog_meta.o \
+ $(top_builddir)/elog-lookup.o \
+ $(top_builddir)/elog-process-metadata.o
+
+
+elog_unittest_CPPFLAGS = $(test_cppflags)
+elog_unittest_CXXFLAGS = $(test_cxxflags)
+elog_unittest_LDFLAGS = $(test_ldflags)
+elog_unittest_SOURCES = elog_unittest.cpp
+
+serialization_test_path_CPPFLAGS = $(test_cppflags)
+serialization_test_path_CXXFLAGS = $(test_cxxflags)
+serialization_test_path_SOURCES = serialization_test_path.cpp
+serialization_test_path_LDADD = $(test_ldadd)
+serialization_test_path_LDFLAGS = \
+ $(test_ldflags) \
+ -lstdc++fs
+
+serialization_test_properties_CPPFLAGS = $(test_cppflags)
+serialization_test_properties_CXXFLAGS = $(test_cxxflags)
+serialization_test_properties_SOURCES = serialization_test_properties.cpp
+serialization_test_properties_LDADD = $(test_ldadd)
+serialization_test_properties_LDFLAGS = \
+ $(test_ldflags) \
+ -lstdc++fs
OpenPOWER on IntegriCloud