summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorDeepak Kodihalli <dkodihal@in.ibm.com>2018-08-30 05:38:44 -0500
committerDeepak Kodihalli <dkodihal@in.ibm.com>2018-08-31 04:41:26 -0500
commit5ac1bde129258d906246f5d4ad78e036f03a6e80 (patch)
tree157de05d5168e111c465bebfedf03067839b2836 /test/Makefile.am
parent834dcf100f87966bdcb322afda4c23fa4135c021 (diff)
downloadphosphor-logging-5ac1bde129258d906246f5d4ad78e036f03a6e80.tar.gz
phosphor-logging-5ac1bde129258d906246f5d4ad78e036f03a6e80.zip
phosphor-rsyslog-conf: add unit tests
Add tests pertaining to remote logging config file. Change-Id: Idaeac09b5abe91af30dc0eb32664e8af556ecda2 Signed-off-by: Deepak Kodihalli <dkodihal@in.ibm.com>
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 0db1650..30e5472 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -7,7 +7,8 @@ check_PROGRAMS = \
serialization_test_path \
serialization_test_properties \
remote_logging_test_address \
- remote_logging_test_port
+ remote_logging_test_port \
+ remote_logging_test_config
test_cppflags = \
-Igtest \
@@ -78,3 +79,11 @@ remote_logging_test_port_LDADD = $(remote_logging_test_ldadd)
remote_logging_test_port_LDFLAGS = \
$(test_ldflags) \
-lstdc++fs
+
+remote_logging_test_config_CPPFLAGS = $(test_cppflags)
+remote_logging_test_config_CXXFLAGS = $(test_cxxflags)
+remote_logging_test_config_SOURCES = remote_logging_test_config.cpp
+remote_logging_test_config_LDADD = $(remote_logging_test_ldadd)
+remote_logging_test_config_LDFLAGS = \
+ $(test_ldflags) \
+ -lstdc++fs
OpenPOWER on IntegriCloud