summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorPatrick Venture <venture@google.com>2018-08-29 11:41:01 -0700
committerPatrick Venture <venture@google.com>2018-11-11 08:21:26 -0800
commit59a6b1f27e83066baa6f3711c88d6a3b9a5c4d49 (patch)
tree56c0b0abc5dd83b3d83ab598f47df663b8561e80 /test/Makefile.am
parent30047bf9647215951ba5dfe21ceb3e58a1b405a4 (diff)
downloadphosphor-logging-59a6b1f27e83066baa6f3711c88d6a3b9a5c4d49.tar.gz
phosphor-logging-59a6b1f27e83066baa6f3711c88d6a3b9a5c4d49.zip
add sdjournal interface to inject tests
The goal of the tests is not to test phosphor-logging, but rather allow code to call through phosphor-logging/log<> during a test. Change-Id: Id8c84ded473decc7f9f0be268116083093f86e54 Signed-off-by: Patrick Venture <venture@google.com>
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 092dd02..08a2537 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -36,9 +36,12 @@ test_ldadd = \
$(top_builddir)/xyz/openbmc_project/Logging/Internal/Manager/server.o \
$(top_builddir)/elog_meta.o \
$(top_builddir)/elog-lookup.o \
- $(top_builddir)/elog-process-metadata.o
+ $(top_builddir)/elog-process-metadata.o \
+ $(top_builddir)/sdjournal.o
-remote_logging_test_ldadd = $(top_builddir)/phosphor-rsyslog-config/server-conf.o
+remote_logging_test_ldadd = \
+ $(top_builddir)/phosphor-rsyslog-config/server-conf.o \
+ $(top_builddir)/sdjournal.o
elog_errorwrap_test_CPPFLAGS = $(test_cppflags)
elog_errorwrap_test_CXXFLAGS = $(test_cxxflags)
OpenPOWER on IntegriCloud