summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAdriana Kobylak <anoo@us.ibm.com>2017-02-06 20:55:39 -0600
committerPatrick Williams <patrick@stwcx.xyz>2017-03-01 16:06:13 +0000
commitebd59fa425c2560fd302cfad7fcfe7f02e3bc3cd (patch)
tree0670865675761294decc9268179666ef3d0d2557 /configure.ac
parentfbe8872e810abd228f08d88d33729997fc1a3483 (diff)
downloadphosphor-logging-ebd59fa425c2560fd302cfad7fcfe7f02e3bc3cd.tar.gz
phosphor-logging-ebd59fa425c2560fd302cfad7fcfe7f02e3bc3cd.zip
Use configure option yaml path to generate elog-errors.hpp
Add a config variable that can be passed via a recipe to point the parser to a directory where the error yaml files are. Rename elog-gen.hpp to elog-errors.hpp, which better matches the exception error log file names. Include elog-gen.hpp in elog.hpp so that callers that need to create and commit error logs only need to include one header file. Change-Id: Ie3cd65ac761c1f7b2c99c50a2273859283a5ab4b Signed-off-by: Adriana Kobylak <anoo@us.ibm.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c99fc1f..10655ed 100644
--- a/configure.ac
+++ b/configure.ac
@@ -63,6 +63,14 @@ AC_DEFINE(BUSNAME_LOGGING, "xyz.openbmc_project.Logging", [The log manager DBus
AC_DEFINE(OBJ_LOGGING, "/xyz/openbmc_project/logging", [The log manager DBus object path.])
AC_DEFINE(OBJ_INTERNAL, "/xyz/openbmc_project/logging/internal/manager", [The private log manager DBus object path.])
AC_DEFINE(OBJ_ENTRY, "/xyz/openbmc_project/logging/entry", [The log entry DBus object path.])
+
+AC_ARG_VAR(YAML_DIR_TEST, [The path to the test error yaml files.])
+AS_IF([test "x$YAML_DIR_TEST" == "x"], \
+ [YAML_DIR_TEST="${srcdir}/tools/"])
+AC_ARG_VAR(YAML_DIR, [The path to the yaml error files.])
+AS_IF([test "x$YAML_DIR" == "x"], \
+ [YAML_DIR="None"])
+
AC_CONFIG_HEADERS([config.h])
AC_CONFIG_FILES([Makefile test/Makefile])
AC_CONFIG_FILES([phosphor-logging.pc])
OpenPOWER on IntegriCloud