summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAdriana Kobylak <anoo@us.ibm.com>2017-01-24 12:30:15 -0600
committerAdriana Kobylak <anoo@us.ibm.com>2017-01-30 12:57:25 -0600
commit88d7cf8da4a7213e4f91d3eca35ec6a2fd8f9ca0 (patch)
tree9d3a907abd251debf41c1af553c69badb67e34b5 /configure.ac
parent7298dc2320ff8b18b16acfb66a06c328c786dd87 (diff)
downloadphosphor-logging-88d7cf8da4a7213e4f91d3eca35ec6a2fd8f9ca0.tar.gz
phosphor-logging-88d7cf8da4a7213e4f91d3eca35ec6a2fd8f9ca0.zip
logging: Create Entry dbus interface
Implement the generated code to create an error/event entry dbus object. Change-Id: I881636fe3e8de680d9a15fff1fe933d5e22eed06 Signed-off-by: Adriana Kobylak <anoo@us.ibm.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 8 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 7d0ce66..d668d7a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,15 +1,17 @@
+# Initialization
AC_PREREQ([2.69])
AC_INIT([phosphor-logging], [1.0], [https://github.com/openbmc/phosphor-logging/issues])
-
AC_LANG([C++])
AM_INIT_AUTOMAKE([subdir-objects -Wall -Werror foreign dist-xz])
-AM_PROG_AR()
AM_SILENT_RULES([yes])
-# Checks for programs
-AC_PROG_CXX
+# Checks for typedefs, structures, and compiler characteristics.
AX_CXX_COMPILE_STDCXX_14([noext])
AX_APPEND_COMPILE_FLAGS([-fpic -Wall -Werror], [CXXFLAGS])
+
+# Checks for programs
+AC_PROG_CXX
+AM_PROG_AR
AC_PROG_INSTALL #Checks/sets the install variable to be used
AC_PROG_MAKE_SET
# Python
@@ -19,6 +21,7 @@ AM_PATH_PYTHON([2.7], [AC_SUBST([PYTHON], [echo "$PYTHON"])], [AC_MSG_ERROR(
# Surpress the --with-libtool-sysroot error
LT_INIT
+# Check for libraries.
PKG_CHECK_MODULES([SYSTEMD], [libsystemd >= 221])
PKG_CHECK_MODULES([SDBUSPLUS], [sdbusplus],,
AC_MSG_ERROR(["Requires sdbusplus package."]))
@@ -55,6 +58,7 @@ AS_IF([test "x$enable_oe_sdk" == "xyes"],
AC_DEFINE(BUSNAME_LOGGING, "xyz.openbmc_project.Logging", [The log manager DBus busname to own.])
AC_DEFINE(OBJ_INTERNAL, "/xyz/openbmc_project/Logging/Internal/Manager", [The private log manager DBus object path.])
+AC_DEFINE(OBJ_ENTRY, "/xyz/openbmc_project/Logging/Entry", [The log entry DBus object path.])
AC_CONFIG_HEADERS([config.h])
AC_CONFIG_FILES([Makefile test/Makefile])
AC_OUTPUT
OpenPOWER on IntegriCloud